aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 02:24:29 +0100
committerMatthias Schiffer <mschiffer@universe-factory.net>2017-01-10 02:24:29 +0100
commit876d139c98a822f04aed2767b08638cd6efd0a45 (patch)
tree3e5d00def373327709dd550999aff635f5b89f91
parent564b13846bbb80e5a0a0dabcd34a59fbbc3f6b4a (diff)
python{,3}: remove STAGING_DIR_HOSTPKG fallback definition
STAGING_DIR_HOSTPKG is now defined in both OpenWrt and LEDE, so we can start to rely on it. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
-rw-r--r--lang/python/files/python-host.mk6
-rw-r--r--lang/python3/files/python3-host.mk6
2 files changed, 0 insertions, 12 deletions
diff --git a/lang/python/files/python-host.mk b/lang/python/files/python-host.mk
index 7833a0c73..ff2ed57d9 100644
--- a/lang/python/files/python-host.mk
+++ b/lang/python/files/python-host.mk
@@ -11,12 +11,6 @@ __python_host_mk_inc=1
# For PYTHON_VERSION
$(call include_mk, python-version.mk)
-# Compatibility fallback for older OpenWrt and LEDE versions
-ifeq ($(STAGING_DIR_HOSTPKG),)
- $(warning STAGING_DIR_HOSTPKG is unset - falling back to $$(STAGING_DIR)/host)
- STAGING_DIR_HOSTPKG := $(STAGING_DIR)/host
-endif
-
HOST_PYTHON_DIR:=$(STAGING_DIR_HOSTPKG)
HOST_PYTHON_INC_DIR:=$(HOST_PYTHON_DIR)/include/python$(PYTHON_VERSION)
HOST_PYTHON_LIB_DIR:=$(HOST_PYTHON_DIR)/lib/python$(PYTHON_VERSION)
diff --git a/lang/python3/files/python3-host.mk b/lang/python3/files/python3-host.mk
index 278b90d90..e9677734f 100644
--- a/lang/python3/files/python3-host.mk
+++ b/lang/python3/files/python3-host.mk
@@ -11,12 +11,6 @@ __python3_host_mk_inc=1
# For PYTHON3_VERSION
$(call include_mk, python3-version.mk)
-# Compatibility fallback for older OpenWrt and LEDE versions
-ifeq ($(STAGING_DIR_HOSTPKG),)
- $(warning STAGING_DIR_HOSTPKG is unset - falling back to $$(STAGING_DIR)/host)
- STAGING_DIR_HOSTPKG := $(STAGING_DIR)/host
-endif
-
HOST_PYTHON3_DIR:=$(STAGING_DIR_HOSTPKG)
HOST_PYTHON3_INC_DIR:=$(HOST_PYTHON3_DIR)/include/python$(PYTHON3_VERSION)
HOST_PYTHON3_LIB_DIR:=$(HOST_PYTHON3_DIR)/lib/python$(PYTHON3_VERSION)