aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStephen Walker <stephendwalker+github@gmail.com>2016-07-19 19:02:02 -0400
committerStephen Walker <stephendwalker+github@gmail.com>2016-07-19 19:02:02 -0400
commit87044ef55ce15a8a73fb6ec50ca70f75348d7787 (patch)
treea023e1a209c6f25d3599482e25075dc622923bb2
parente54025a3f40e8abdb9c723da596e70d883d1326f (diff)
linuxptp: pass TARGET_CFLAGS using MAKE_VARS, bump PKG_RELEASE
ccache_cc -Wall -DVER=1.6 -D_GNU_SOURCE -DHAVE_CLOCK_ADJTIME -DHAVE_POSIX_SPAWN -DHAVE_ONESTEP_SYNC -c -o ptp4l.o ptp4l.c cc1: note: someone does not honour COPTS correctly, passed 0 times unpatched 8229 hwstamp_ctl 128213 phc2sys 37045 phc_ctl 99077 pmc 185589 ptp4l 41141 timemaster patched (honouring -Os CFLAG) 8213 hwstamp_ctl 54469 phc2sys 20645 phc_ctl 49877 pmc 74965 ptp4l 20645 timemaster Signed-off-by: Stephen Walker <stephendwalker+github@gmail.com>
-rw-r--r--net/linuxptp/Makefile7
1 files changed, 5 insertions, 2 deletions
diff --git a/net/linuxptp/Makefile b/net/linuxptp/Makefile
index 9bc881da9..88edd155a 100644
--- a/net/linuxptp/Makefile
+++ b/net/linuxptp/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2015-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=linuxptp
PKG_VERSION:=20151118
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_REV:=999c86f4a9da4bf4508b3a69289f58166ed18a55
PKG_MAINTAINER:=Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
@@ -41,6 +41,9 @@ define Package/linuxptp/description
computers.
endef
+MAKE_VARS += \
+ EXTRA_CFLAGS="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS)"
+
define Package/linuxptp/install
$(INSTALL_DIR) $(1)/usr/sbin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hwstamp_ctl $(1)/usr/sbin/