aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHirokazu MORIKAWA <register@nxhack.com>2016-05-27 16:22:39 +0900
committerHirokazu MORIKAWA <register@nxhack.com>2016-05-27 16:22:39 +0900
commit865f44ef7736e1aad70a7b1f62cd8dfea62387f1 (patch)
tree68f3aa44d4651dfbf41a6c4b1fbb5404ed8765f8
parent959d3a418602e712191bed0ebaf8ec2603500cfc (diff)
node,node-*: node update to v4.4.5 and Enhance CPU-arch variant.
-rw-r--r--lang/node-arduino-firmata/Makefile4
-rw-r--r--lang/node-cylon/Makefile4
-rw-r--r--lang/node-hid/Makefile4
-rw-r--r--lang/node-serialport/Makefile4
-rw-r--r--lang/node/Makefile8
-rw-r--r--lang/node/patches/004-gcc6-undefined-behaviour.patch64
6 files changed, 12 insertions, 76 deletions
diff --git a/lang/node-arduino-firmata/Makefile b/lang/node-arduino-firmata/Makefile
index 58dc2417e..d90a6048e 100644
--- a/lang/node-arduino-firmata/Makefile
+++ b/lang/node-arduino-firmata/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=arduino-firmata
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=0.3.3
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/shokai/node-arduino-firmata.git
@@ -19,7 +19,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_DEPENDS:=node/host
-PKG_NODE_VERSION:=4.4.4
+PKG_NODE_VERSION:=4.4.5
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=MIT
diff --git a/lang/node-cylon/Makefile b/lang/node-cylon/Makefile
index ad7e52578..07e56a63e 100644
--- a/lang/node-cylon/Makefile
+++ b/lang/node-cylon/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=cylon
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=0.22.0
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/hybridgroup/cylon-firmata.git
@@ -19,7 +19,7 @@ PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_SOURCE_VERSION)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_DEPENDS:=node/host
-PKG_NODE_VERSION:=4.4.4
+PKG_NODE_VERSION:=4.4.5
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=Apache-2.0
diff --git a/lang/node-hid/Makefile b/lang/node-hid/Makefile
index fb29eae49..e5d5c70fd 100644
--- a/lang/node-hid/Makefile
+++ b/lang/node-hid/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=hid
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=0.5.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/node-hid/node-hid.git
@@ -19,7 +19,7 @@ PKG_SOURCE_VERSION:=35d830b7810c87d32484d0a346621568c4849441
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_DEPENDS:=node/host
-PKG_NODE_VERSION:=4.4.4
+PKG_NODE_VERSION:=4.4.5
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=Custom
diff --git a/lang/node-serialport/Makefile b/lang/node-serialport/Makefile
index b787479e5..e4ca1eba3 100644
--- a/lang/node-serialport/Makefile
+++ b/lang/node-serialport/Makefile
@@ -10,14 +10,14 @@ include $(TOPDIR)/rules.mk
PKG_NPM_NAME:=serialport
PKG_NAME:=node-$(PKG_NPM_NAME)
PKG_VERSION:=3.0.0
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NPM_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=http://registry.npmjs.org/$(PKG_NPM_NAME)/-/
PKG_MD5SUM:=ea20a17746dd64e72d5f6f2019d9e28d
PKG_BUILD_DEPENDS:=node/host
-PKG_NODE_VERSION:=4.4.4
+PKG_NODE_VERSION:=4.4.5
PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
PKG_LICENSE:=Custom
diff --git a/lang/node/Makefile b/lang/node/Makefile
index 7effb08ea..4f9aa7960 100644
--- a/lang/node/Makefile
+++ b/lang/node/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=node
-PKG_VERSION:=v4.4.4
+PKG_VERSION:=v4.4.5
PKG_RELEASE:=1
PKG_SOURCE:=node-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://nodejs.org/dist/${PKG_VERSION}
-PKG_MD5SUM:=1ad7915688df85f62a57f43860dc54c6
+PKG_MD5SUM:=376140907bbe362f36065a30af04f020
HOST_BUILD_DEPENDS:=python/host
PKG_BUILD_DEPENDS:=python/host
@@ -35,7 +35,7 @@ define Package/node
SUBMENU:=Node.js
TITLE:=Node.js is a platform built on Chrome's JavaScript runtime
URL:=http://nodejs.org/
- DEPENDS:=+libpthread +librt +libstdcpp +libopenssl +libuv +zlib
+ DEPENDS:=+libpthread +librt +libstdcpp +libopenssl +zlib
endef
define Package/node/description
@@ -44,7 +44,7 @@ define Package/node/description
package ecosystem, npm, is the largest ecosystem of open source libraries in the world.
endef
-CPU:=$(subst x86_64,x64,$(subst i386,ia32,$(ARCH)))
+CPU:=$(subst aarch64,arm64,$(subst x86_64,x64,$(subst i386,ia32,$(ARCH))))
MAKE_VARS += \
DESTCPU=$(CPU)
diff --git a/lang/node/patches/004-gcc6-undefined-behaviour.patch b/lang/node/patches/004-gcc6-undefined-behaviour.patch
deleted file mode 100644
index 11b01325d..000000000
--- a/lang/node/patches/004-gcc6-undefined-behaviour.patch
+++ /dev/null
@@ -1,64 +0,0 @@
-diff --git a/deps/v8/src/heap/incremental-marking.cc b/deps/v8/src/heap/incremental-marking.cc
-index 58eb0aa..b2b796f 100644
---- a/deps/v8/src/heap/incremental-marking.cc
-+++ b/deps/v8/src/heap/incremental-marking.cc
-@@ -364,7 +364,7 @@ void IncrementalMarking::DeactivateIncrementalWriteBarrier() {
- DeactivateIncrementalWriteBarrierForSpace(heap_->new_space());
-
- LargePage* lop = heap_->lo_space()->first_page();
-- while (lop->is_valid()) {
-+ while (LargePage::IsValid(lop)) {
- SetOldSpacePageFlags(lop, false, false);
- lop = lop->next_page();
- }
-@@ -396,7 +396,7 @@ void IncrementalMarking::ActivateIncrementalWriteBarrier() {
- ActivateIncrementalWriteBarrier(heap_->new_space());
-
- LargePage* lop = heap_->lo_space()->first_page();
-- while (lop->is_valid()) {
-+ while (LargePage::IsValid(lop)) {
- SetOldSpacePageFlags(lop, true, is_compacting_);
- lop = lop->next_page();
- }
-diff --git a/deps/v8/src/heap/spaces-inl.h b/deps/v8/src/heap/spaces-inl.h
-index c2c4d12..d63ee63 100644
---- a/deps/v8/src/heap/spaces-inl.h
-+++ b/deps/v8/src/heap/spaces-inl.h
-@@ -155,7 +155,7 @@ Page* Page::Initialize(Heap* heap, MemoryChunk* chunk, Executability executable,
-
- bool PagedSpace::Contains(Address addr) {
- Page* p = Page::FromAddress(addr);
-- if (!p->is_valid()) return false;
-+ if (!Page::IsValid(p)) return false;
- return p->owner() == this;
- }
-
-diff --git a/deps/v8/src/heap/spaces.cc b/deps/v8/src/heap/spaces.cc
-index 0806b25..c0e109b 100644
---- a/deps/v8/src/heap/spaces.cc
-+++ b/deps/v8/src/heap/spaces.cc
-@@ -2953,7 +2953,7 @@ LargePage* LargeObjectSpace::FindPage(Address a) {
- if (e != NULL) {
- DCHECK(e->value != NULL);
- LargePage* page = reinterpret_cast<LargePage*>(e->value);
-- DCHECK(page->is_valid());
-+ DCHECK(LargePage::IsValid(page));
- if (page->Contains(a)) {
- return page;
- }
-diff --git a/deps/v8/src/heap/spaces.h b/deps/v8/src/heap/spaces.h
-index 3461de3..e35c057 100644
---- a/deps/v8/src/heap/spaces.h
-+++ b/deps/v8/src/heap/spaces.h
-@@ -278,9 +278,9 @@ class MemoryChunk {
- // Only works for addresses in pointer spaces, not data or code spaces.
- static inline MemoryChunk* FromAnyPointerAddress(Heap* heap, Address addr);
-
-- Address address() { return reinterpret_cast<Address>(this); }
-+ static bool IsValid(MemoryChunk* chunk) { return chunk != nullptr; }
-
-- bool is_valid() { return address() != NULL; }
-+ Address address() { return reinterpret_cast<Address>(this); }
-
- MemoryChunk* next_chunk() const {
- return reinterpret_cast<MemoryChunk*>(base::Acquire_Load(&next_chunk_));