aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>2014-09-29 21:33:15 +0200
committerNikos Mavrogiannopoulos <n.mavrogiannopoulos@gmail.com>2014-09-29 21:33:15 +0200
commit832aa53af9cc940c19552511a13ed64db6c158b3 (patch)
tree284bd5cabd871057e30b85b33b53ac7553f5c67f
parent04f18ac5a2bdfdd0e1499a213f646193e5a93581 (diff)
parentd470bafa90a923a87035b27948a34f70def29edd (diff)
Merge pull request #377 from chris5560/master
ddns-scripts: fix from ticket #17998 wrongly detect ipv4 address start with 10x.x.x.x
-rw-r--r--net/ddns-scripts/Makefile2
-rw-r--r--net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh2
2 files changed, 2 insertions, 2 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 6193fbbe1..c57757ba1 100644
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ddns-scripts
PKG_VERSION:=2.0.1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_LICENSE:=GPL-2.0
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
diff --git a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
index 63e49bd82..778735bea 100644
--- a/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/dynamic_dns_functions.sh
@@ -553,7 +553,7 @@ send_update() {
local __IP __URL __ANSWER __ERR
# verify given IP
- [ $use_ipv6 -eq 0 ] && __IP=$(echo $1 | grep -v -E "(^0|^10|^127|^172|^192)") # no private IPv4's
+ [ $use_ipv6 -eq 0 ] && __IP=$(echo $1 | grep -v -E "(^0|^10\.|^127|^172|^192)") # no private IPv4's
[ $use_ipv6 -eq 1 ] && __IP=$(echo $1 | grep "^[0-9a-eA-E]") # no IPv6 addr starting with fxxx of with ":"
[ -z "$__IP" ] && critical_error "Invalid or no IP '$1' given"