aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2015-04-20 22:45:40 +0200
committerNicolas Thill <nico@openwrt.org>2015-04-20 22:45:40 +0200
commit82ce4b745ca083288fd04cabc8104caa758f4d46 (patch)
treecbc2ec3864be4745cf165e3828b0c7aa2a244262
parent3828a7096d1dc8bf84f83902519cf0f1800c6c60 (diff)
bzip2: move packages in a "Compression" submenu
Signed-off-by: Nicolas Thill <nico@openwrt.org>
-rw-r--r--utils/bzip2/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/utils/bzip2/Makefile b/utils/bzip2/Makefile
index c633344cf..bf5bcf822 100644
--- a/utils/bzip2/Makefile
+++ b/utils/bzip2/Makefile
@@ -21,12 +21,17 @@ PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
+define Package/bzip2/Default
+ SUBMENU:=Compression
+ URL:=http://www.bzip.org/
+endef
+
define Package/libbz2
+$(call Package/bzip2/Default)
SECTION:=libs
CATEGORY:=Libraries
DEPENDS:=
TITLE:=bzip2 library.
- URL:=http://www.bzip.org/
endef
define Package/libbz2/description
@@ -35,11 +40,11 @@ define Package/libbz2/description
endef
define Package/bzip2
+$(call Package/bzip2/Default)
SECTION:=utils
CATEGORY:=Utilities
DEPENDS:=+libbz2
TITLE:=bzip2 is a compression utility.
- URL:=http://www.bzip.org/
endef
define Package/bzip2/description