aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Golle <dangowrt@users.noreply.github.com>2015-06-21 21:32:20 +0200
committerDaniel Golle <dangowrt@users.noreply.github.com>2015-06-21 21:32:20 +0200
commit82901096f1dfd0706625ecef7e382605228adf12 (patch)
tree2facfdd7a92531ffa27b178108eeda2ff2021611
parent60ba8483f14c17a553ef7c3674246d9de2fdd95b (diff)
parentdf1df03a2f5b54b2f22c6e4f988597107ac5981e (diff)
Merge pull request #1447 from dangowrt/libarchive-without-openssl
libarchive: add build-variant without libopenssl
-rw-r--r--libs/libarchive/Makefile31
1 files changed, 25 insertions, 6 deletions
diff --git a/libs/libarchive/Makefile b/libs/libarchive/Makefile
index 91bbe5462..9c42aad14 100644
--- a/libs/libarchive/Makefile
+++ b/libs/libarchive/Makefile
@@ -22,12 +22,23 @@ PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
-define Package/libarchive
- SECTION:=libs
- CATEGORY:=Libraries
- DEPENDS:=+libopenssl +zlib
- TITLE:=Multi-format archive and compression library
- URL:=http://www.libarchive.org/
+define Package/$(PKG_NAME)/Default
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+zlib
+ TITLE:=Multi-format archive and compression library
+ URL:=http://www.libarchive.org/
+endef
+
+define Package/$(PKG_NAME)
+ $(call Package/$(PKG_NAME)/Default)
+ DEPENDS += +libopenssl
+endef
+
+define Package/$(PKG_NAME)-noopenssl
+ $(call Package/$(PKG_NAME)/Default)
+ TITLE += (without OpenSSL dependency)
+ VARIANT:=noopenssl
endef
CONFIGURE_ARGS += \
@@ -43,6 +54,12 @@ CONFIGURE_ARGS += \
--without-expat \
--without-xml2
+ifeq ($(BUILD_VARIANT),noopenssl)
+ CONFIGURE_ARGS += --without-openssl
+else
+ CONFIGURE_ARGS += --with-openssl
+endif
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
@@ -54,5 +71,7 @@ define Package/libarchive/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so.* $(1)/usr/lib/
endef
+Package/$(PKG_NAME)-noopenssl/install = $(Package/$(PKG_NAME)/install)
$(eval $(call BuildPackage,libarchive))
+$(eval $(call BuildPackage,libarchive-noopenssl))