aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-01-10 18:20:53 +0200
committerGitHub <noreply@github.com>2018-01-10 18:20:53 +0200
commit820b3325bf7e70ea252666d7d9b17df0ad9a3a62 (patch)
tree9264bcf3e2be3f1cd5d5c05d0b25766992a10ad8
parentc3f054eaa552286bced18e3c8f4d008b1e8c11cb (diff)
parentf47dfab5aecaaf1bfd737361e1ef343e13d9941d (diff)
Merge pull request #5404 from jefferyto/python-cryptography-2.1.4
python-cryptography: update to 2.1.4, refresh patches
-rw-r--r--lang/python/python-cryptography/Makefile8
-rw-r--r--lang/python/python-cryptography/patches/001-disable-setup-requirements.patch4
-rw-r--r--lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch4
3 files changed, 6 insertions, 10 deletions
diff --git a/lang/python/python-cryptography/Makefile b/lang/python/python-cryptography/Makefile
index fdabd483e..acae27fe7 100644
--- a/lang/python/python-cryptography/Makefile
+++ b/lang/python/python-cryptography/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2015-2016 OpenWrt.org
+# Copyright (C) 2015-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-cryptography
-PKG_VERSION:=2.1.3
+PKG_VERSION:=2.1.4
PKG_RELEASE:=1
PKG_SOURCE:=cryptography-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://pypi.python.org/packages/f3/7c/ec4f94489719803cb14d35e9625d1f5a613b9c4b8d01ee52a4c77485e681
-PKG_HASH:=68a26c353627163d74ee769d4749f2ee243866e9dac43c93bb33ebd8fbed1199
+PKG_SOURCE_URL:=https://pypi.python.org/packages/78/c5/7188f15a92413096c93053d5304718e1f6ba88b818357d05d19250ebff85
+PKG_HASH:=e4d967371c5b6b2e67855066471d844c5d52d210c36c28d49a8507b96e2c5291
PKG_LICENSE:=Apache-2.0 BSD-3-Clause
PKG_LICENSE_FILES:=LICENSE.APACHE LICENSE.BSD
diff --git a/lang/python/python-cryptography/patches/001-disable-setup-requirements.patch b/lang/python/python-cryptography/patches/001-disable-setup-requirements.patch
index 07ae483c2..65781af52 100644
--- a/lang/python/python-cryptography/patches/001-disable-setup-requirements.patch
+++ b/lang/python/python-cryptography/patches/001-disable-setup-requirements.patch
@@ -1,8 +1,6 @@
-diff --git a/setup.py b/setup.py
-index b5c05df..a777dd7 100644
--- a/setup.py
+++ b/setup.py
-@@ -266,6 +266,7 @@ class DummyPyTest(test):
+@@ -235,6 +235,7 @@ class DummyPyTest(test):
with open(os.path.join(base_dir, "README.rst")) as f:
long_description = f.read()
diff --git a/lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch b/lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch
index 3b7aaf396..25ad27d7c 100644
--- a/lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch
+++ b/lang/python/python-cryptography/patches/002-remove-undefined-dtls-methods.patch
@@ -1,8 +1,6 @@
-diff --git a/src/_cffi_src/openssl/ssl.py b/src/_cffi_src/openssl/ssl.py
-index 8bda4e0..aa81060 100644
--- a/src/_cffi_src/openssl/ssl.py
+++ b/src/_cffi_src/openssl/ssl.py
-@@ -595,9 +595,6 @@ static const long TLS_ST_OK = 0;
+@@ -597,9 +597,6 @@ static const long TLS_ST_OK = 0;
#if defined(OPENSSL_NO_DTLS) || CRYPTOGRAPHY_OPENSSL_LESS_THAN_102
static const long Cryptography_HAS_GENERIC_DTLS_METHOD = 0;