aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2017-11-17 06:48:38 -0500
committerGitHub <noreply@github.com>2017-11-17 06:48:38 -0500
commit8170176bc05bb1782e49e7898e7ae26b9fa685ca (patch)
tree28e024f66237a2f34cecee30f16cdefca5ed9cf1
parenta2de0d04b4be837f8da171af367e65d3e7b4d7cf (diff)
parent35bf4d15d4b3a0c048bf2bac2c345e2184bbe3b9 (diff)
Merge pull request #5136 from lynxis/rb_avrdude
avrdude: add no timestamp patch to make it reproducible
-rw-r--r--utils/avrdude/Makefile2
-rw-r--r--utils/avrdude/patches/020-no-cpp-timestamps.patch21
2 files changed, 22 insertions, 1 deletions
diff --git a/utils/avrdude/Makefile b/utils/avrdude/Makefile
index 9fa7660f7..c87027f15 100644
--- a/utils/avrdude/Makefile
+++ b/utils/avrdude/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=avrdude
PKG_VERSION:=6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=@SAVANNAH/$(PKG_NAME)
diff --git a/utils/avrdude/patches/020-no-cpp-timestamps.patch b/utils/avrdude/patches/020-no-cpp-timestamps.patch
new file mode 100644
index 000000000..8427055af
--- /dev/null
+++ b/utils/avrdude/patches/020-no-cpp-timestamps.patch
@@ -0,0 +1,21 @@
+Description: no CPP macro timestamps
+ Reporducible builds project support, see:
+ http://wiki.debian.org/ReproducibleBuilds/TimestampsFromCPPMacros
+Author: Milan Kupcevic <milan@debian.org>
+---
+This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
+--- a/main.c
++++ b/main.c
+@@ -679,10 +679,10 @@
+ * Print out an identifying string so folks can tell what version
+ * they are running
+ */
+- avrdude_message(MSG_NOTICE, "\n%s: Version %s, compiled on %s at %s\n"
++ avrdude_message(MSG_NOTICE, "\n%s: Version %s\n"
+ "%sCopyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/\n"
+ "%sCopyright (c) 2007-2014 Joerg Wunsch\n\n",
+- progname, version, __DATE__, __TIME__, progbuf, progbuf);
++ progname, version, progbuf, progbuf);
+ avrdude_message(MSG_NOTICE, "%sSystem wide configuration file is \"%s\"\n",
+ progbuf, sys_config);
+