aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2021-03-03 13:51:31 +0100
committerJan Pavlinec <jan.pavlinec@nic.cz>2021-03-23 10:55:10 +0100
commit8133922a029adbc0cec32cc64c4cbbb16cf82da5 (patch)
tree224970f14cebed3543725001519c27aba461760c
parentae0556e6a53f85948448f04d1bc22884906f727e (diff)
python-flask-socketio: add new package
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
-rw-r--r--lang/python/python-flask-socketio/Makefile44
1 files changed, 44 insertions, 0 deletions
diff --git a/lang/python/python-flask-socketio/Makefile b/lang/python/python-flask-socketio/Makefile
new file mode 100644
index 000000000..945d57aa3
--- /dev/null
+++ b/lang/python/python-flask-socketio/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-flask-socketio
+PKG_VERSION:=5.0.1
+PKG_RELEASE:=1
+
+PYPI_NAME:=Flask-SocketIO
+PKG_HASH:=5c4319f5214ada20807857dc8fdf3dc7d2afe8d6dd38f5c516c72e2be47d2227
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-flask-socketio
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Socket.IO integration for Flask
+ URL:=https://github.com/miguelgrinberg/Flask-SocketIO/
+ DEPENDS:= \
+ +python3-light \
+ +python3-flask \
+ +python3-socketio
+endef
+
+define Package/python3-flask-socketio/description
+ Flask-SocketIO gives Flask applications access to low latency
+ bi-directional communications between the clients and the server.
+endef
+
+$(eval $(call Py3Package,python3-flask-socketio))
+$(eval $(call BuildPackage,python3-flask-socketio))
+$(eval $(call BuildPackage,python3-flask-socketio-src))