aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndy Walsh <andy.walsh44+github@gmail.com>2021-06-27 15:15:26 +0200
committerAndy Walsh <andy.walsh44+github@gmail.com>2021-06-27 15:32:34 +0200
commit7f3f6d162ae6bb3924a25f37f82efc54dee2c49f (patch)
tree48e01a7ef91ad5f1f8af5c7f4d78a81936a4abf1
parent7b9c04f95b5202d5eb75e4bf1c6831a667ac3d0f (diff)
samba4: update to 4.14.5
* update to 4.14.5 * refresh patches Signed-off-by: Andy Walsh <andy.walsh44+github@gmail.com>
-rw-r--r--net/samba4/Makefile4
-rw-r--r--net/samba4/patches/001-samba-4.4.0-pam.patch4
-rw-r--r--net/samba4/patches/006-netdb-defines.patch2
-rw-r--r--net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch4
-rw-r--r--net/samba4/patches/008-samba-4.11-add_missing___compar_fn_t.patch6
-rw-r--r--net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch4
-rw-r--r--net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch6
7 files changed, 16 insertions, 14 deletions
diff --git a/net/samba4/Makefile b/net/samba4/Makefile
index 06c97bc82..f3108fc58 100644
--- a/net/samba4/Makefile
+++ b/net/samba4/Makefile
@@ -2,7 +2,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=samba
-PKG_VERSION:=4.13.9
+PKG_VERSION:=4.14.5
PKG_RELEASE:=$(AUTORELEASE)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -13,7 +13,7 @@ PKG_SOURCE_URL:= \
http://www.nic.funet.fi/index/samba/pub/samba/stable/ \
http://samba.mirror.bit.nl/samba/ftp/stable/ \
https://download.samba.org/pub/samba/stable/
-PKG_HASH:=b97a773ed3b4dae6d5ebd3e09337c897ae898b65f38abad550f852b594d4e07f
+PKG_HASH:=bb6ef5d2f16b85288d823578abc453d9a80514c42e5a2ea2c4e3c60dc42335c3
PKG_MAINTAINER:=Andy Walsh <andy.walsh44+github@gmail.com>
PKG_LICENSE:=GPL-3.0-only
diff --git a/net/samba4/patches/001-samba-4.4.0-pam.patch b/net/samba4/patches/001-samba-4.4.0-pam.patch
index f52e2efb2..72de06619 100644
--- a/net/samba4/patches/001-samba-4.4.0-pam.patch
+++ b/net/samba4/patches/001-samba-4.4.0-pam.patch
@@ -1,6 +1,6 @@
--- a/source3/wscript
+++ b/source3/wscript
-@@ -907,7 +907,7 @@ msg.msg_accrightslen = sizeof(fd);
+@@ -885,7 +885,7 @@ msg.msg_accrightslen = sizeof(fd);
if conf.env.with_iconv:
conf.DEFINE('HAVE_ICONV', 1)
@@ -9,7 +9,7 @@
use_pam=True
conf.CHECK_HEADERS('security/pam_appl.h pam/pam_appl.h')
if not conf.CONFIG_SET('HAVE_SECURITY_PAM_APPL_H') and not conf.CONFIG_SET('HAVE_PAM_PAM_APPL_H'):
-@@ -984,6 +984,17 @@ int i; i = PAM_RADIO_TYPE;
+@@ -962,6 +962,17 @@ int i; i = PAM_RADIO_TYPE;
"or headers not found. Use --without-pam to disable "
"PAM support.");
diff --git a/net/samba4/patches/006-netdb-defines.patch b/net/samba4/patches/006-netdb-defines.patch
index 7cb073c15..a11f8d15c 100644
--- a/net/samba4/patches/006-netdb-defines.patch
+++ b/net/samba4/patches/006-netdb-defines.patch
@@ -1,6 +1,6 @@
--- a/nsswitch/wins.c
+++ b/nsswitch/wins.c
-@@ -39,6 +39,14 @@ static pthread_mutex_t wins_nss_mutex =
+@@ -40,6 +40,14 @@ static pthread_mutex_t wins_nss_mutex =
#define INADDRSZ 4
#endif
diff --git a/net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch b/net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch
index 192cf564d..29928976b 100644
--- a/net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch
+++ b/net/samba4/patches/007-libldb-fix-musl-libc-unkown-type-error.patch
@@ -22,5 +22,5 @@ Signed-off-by: Changqing Li <changqing.li@windriver.com>
+#include <sys/stat.h>
+#include <sys/types.h>
- struct tevent_context;
- struct tevent_ops;
+ /* for old gcc releases that don't have the feature test macro __has_attribute */
+ #ifndef __has_attribute
diff --git a/net/samba4/patches/008-samba-4.11-add_missing___compar_fn_t.patch b/net/samba4/patches/008-samba-4.11-add_missing___compar_fn_t.patch
index 96b65e6c5..401835df8 100644
--- a/net/samba4/patches/008-samba-4.11-add_missing___compar_fn_t.patch
+++ b/net/samba4/patches/008-samba-4.11-add_missing___compar_fn_t.patch
@@ -1,8 +1,8 @@
--- a/source4/dsdb/samdb/ldb_modules/count_attrs.c
+++ b/source4/dsdb/samdb/ldb_modules/count_attrs.c
-@@ -38,6 +38,11 @@
- #define NULL_REQ_PSEUDO_N -2LL;
- #define STAR_REQ_PSEUDO_N -4LL;
+@@ -40,6 +40,11 @@
+
+ #undef strcasecmp
+#ifndef __COMPAR_FN_T
+#define __COMPAR_FN_T
diff --git a/net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch b/net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch
index 507b74c9c..284c09d85 100644
--- a/net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch
+++ b/net/samba4/patches/009-samba-4-11-fix-host-tools-checks.patch.patch
@@ -1,6 +1,8 @@
--- a/wscript_configure_embedded_heimdal
+++ b/wscript_configure_embedded_heimdal
-@@ -1 +1,12 @@
+@@ -2,3 +2,14 @@ if not conf.env['FLEX']:
+ conf.fatal("Embedded Heimdal build requires flex but it was not found. Install flex or use --with-system-mitkrb5 or --with-system-heimdalkrb5")
+
conf.RECURSE('source4/heimdal_build')
+
+def check_system_heimdal_binary(name):
diff --git a/net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch b/net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch
index 8bb80897d..a1b97e0f3 100644
--- a/net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch
+++ b/net/samba4/patches/102-samba-4.11-unbundle-libbsd.patch
@@ -29,7 +29,7 @@
conf.CHECK_CODE('''
struct ucred cred;
-@@ -809,9 +800,6 @@ def configure(conf):
+@@ -807,9 +798,6 @@ def configure(conf):
# look for a method of finding the list of network interfaces
for method in ['HAVE_IFACE_GETIFADDRS', 'HAVE_IFACE_AIX', 'HAVE_IFACE_IFCONF', 'HAVE_IFACE_IFREQ']:
@@ -39,7 +39,7 @@
if conf.CHECK_CODE('''
#define %s 1
#define NO_CONFIG_H 1
-@@ -824,7 +812,7 @@ def configure(conf):
+@@ -822,7 +810,7 @@ def configure(conf):
#include "tests/getifaddrs.c"
''' % method,
method,
@@ -48,7 +48,7 @@
addmain=False,
execute=True):
break
-@@ -872,7 +860,6 @@ def build(bld):
+@@ -870,7 +858,6 @@ def build(bld):
break
extra_libs = ''