aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkrant <aleksey.vasilenko@gmail.com>2024-02-28 13:50:10 +0200
committerkrant <aleksey.vasilenko@gmail.com>2024-02-28 13:50:10 +0200
commit7eeda7fd3e89943f7f5e139950745bb4f90bf904 (patch)
tree5d8fc1ce967150a07ee49e0c48d70943102d6c76
parent03c90979c0fee527009e2dbdf17cb06e8474334e (diff)
inotify-tools: fix link error on x86
Previous commit removed unnecessary linking with libstdc++ but introduced another error on x86 platforms: undefined reference to `__stack_chk_fail_local' Fix it by explicitly linking libssp_nonshared.a Signed-off-by: krant <aleksey.vasilenko@gmail.com>
-rw-r--r--utils/inotify-tools/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/utils/inotify-tools/Makefile b/utils/inotify-tools/Makefile
index 6d537a828..1a81c5e0b 100644
--- a/utils/inotify-tools/Makefile
+++ b/utils/inotify-tools/Makefile
@@ -3,7 +3,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=inotify-tools
PKG_VERSION:=4.23.9.0
PKG_HASH:=1dfa33f80b6797ce2f6c01f454fd486d30be4dca1b0c5c2ea9ba3c30a5c39855
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE_URL:=https://codeload.github.com/rvoicilas/inotify-tools/tar.gz/$(PKG_VERSION)?
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
@@ -25,6 +25,7 @@ endif
## Avoid linking with libstdcpp
TARGET_CXXFLAGS+= -nodefaultlibs -lc -fno-exceptions
+TARGET_LDFLAGS+= $(if $(CONFIG_USE_MUSL),-lssp_nonshared)
define Build/Prepare
$(call Build/Prepare/Default)