aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHuangbin Zhan <zhanhb88@gmail.com>2020-12-09 06:30:54 +0800
committerHuangbin Zhan <zhanhb88@gmail.com>2020-12-09 06:30:54 +0800
commit7ec279ad3e8c97901afbdbc46ebe7e37b8a8137a (patch)
tree414df2248095af8a7b59d2a5795ca1438ecd9612
parent7218ff0318b04e26e756e8a3ceb01a0b607956fa (diff)
less: move binary of alternatives to /usr/libexec
Signed-off-by: Huangbin Zhan <zhanhb88@gmail.com>
-rw-r--r--utils/less/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/utils/less/Makefile b/utils/less/Makefile
index ef0cfa916..2f1b2f291 100644
--- a/utils/less/Makefile
+++ b/utils/less/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=less
PKG_VERSION:=562
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.greenwoodsoftware.com/less
@@ -30,7 +30,7 @@ define Package/less/Default
CATEGORY:=Utilities
TITLE:=Pager program similar to more
URL:=http://www.greenwoodsoftware.com/less/
- ALTERNATIVES:=200:/usr/bin/less:/usr/bin/gnu-less
+ ALTERNATIVES:=200:/usr/bin/less:/usr/libexec/less-gnu
endef
define Package/less/Default/description
@@ -70,8 +70,8 @@ ifeq ($(BUILD_VARIANT),wide)
endif
define Package/less/install
- $(INSTALL_DIR) $(1)/usr/bin
- $(CP) $(PKG_INSTALL_DIR)/usr/bin/less $(1)/usr/bin/gnu-less
+ $(INSTALL_DIR) $(1)/usr/libexec
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/less $(1)/usr/libexec/less-gnu
endef
Package/less-wide/install = $(Package/less/install)