aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-04-13 23:34:39 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-18 15:29:24 -0700
commit7e59e8947a4d98322d84f3cd3f5a7ed80e571814 (patch)
treea04abc76eb09673e3c0e615ee77b804a9317887c
parent4426e4c69b3edbc7dca679c71769c690318b4659 (diff)
powertop: fix compilation with glibc
It seems several libraries need to be linked. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/powertop/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/utils/powertop/Makefile b/utils/powertop/Makefile
index 4fa32c542..68953d493 100644
--- a/utils/powertop/Makefile
+++ b/utils/powertop/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=powertop
PKG_VERSION:=2.10
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-v$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://01.org/sites/default/files/downloads/
@@ -39,13 +39,10 @@ define Package/powertop/description
and power management.
endef
-TARGET_CFLAGS += $(FPIC)
-ifeq ($(CONFIG_USE_UCLIBC),y)
-TARGET_CFLAGS += -fno-stack-protector
-endif
-TARGET_LDFLAGS += $(if $(INTL_FULL),-lintl)
-
-CONFIGURE_ARGS += --without-pic
+TARGET_LDFLAGS += \
+ $(if $(INTL_FULL),-lintl) \
+ $(if $(CONFIG_USE_GLIBC),-lm) \
+ $(if $(CONFIG_USE_GLIBC),-lpthread)
define Package/powertop/install
$(INSTALL_DIR) $(1)/usr/sbin