aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorchamptar <champetier.etienne@gmail.com>2016-07-02 14:42:25 +0200
committerGitHub <noreply@github.com>2016-07-02 14:42:25 +0200
commit7d5e546887763bc930ff9af65759519faab7adfe (patch)
tree6cf046ab04749e5d16c58c56080827d6059dfad6
parentdad2cd4f4bbbb6a3c2a35ecb5787fe8b2166580f (diff)
parent3048ebedec5b989a621529eec159cf5aa17b58b6 (diff)
Merge pull request #2893 from jow-/procps-ng-fix
procps-ng: fix build on systems without gettext development utilities
-rw-r--r--utils/procps-ng/Makefile7
-rw-r--r--utils/procps-ng/patches/100-no-tests-docs.patch26
2 files changed, 30 insertions, 3 deletions
diff --git a/utils/procps-ng/Makefile b/utils/procps-ng/Makefile
index 44badfe02..a50ea8113 100644
--- a/utils/procps-ng/Makefile
+++ b/utils/procps-ng/Makefile
@@ -21,6 +21,7 @@ PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
PKG_BUILD_PARALLEL:=1
PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
include $(INCLUDE_DIR)/package.mk
@@ -39,9 +40,9 @@ define Package/procps-ng/Default
MAINTAINER:=Gergely Kiss <mail.gery@gmail.com>
endef
-define Build/Configure
- (cd $(PKG_BUILD_DIR); echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"; ./autogen.sh );
- $(call Build/Configure/Default)
+define Build/Prepare
+ $(call Build/Prepare/Default)
+ echo "$(PKG_VERSION)" > "$(PKG_BUILD_DIR)/.tarball-version"
endef
define Package/procps-ng
diff --git a/utils/procps-ng/patches/100-no-tests-docs.patch b/utils/procps-ng/patches/100-no-tests-docs.patch
new file mode 100644
index 000000000..50ef7fbf6
--- /dev/null
+++ b/utils/procps-ng/patches/100-no-tests-docs.patch
@@ -0,0 +1,26 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -13,10 +13,7 @@ PACKAGE_VERSION = @PACKAGE_VERSION@
+
+ ACLOCAL_AMFLAGS = -I m4
+ SUBDIRS = \
+- include \
+- man-po \
+- po \
+- testsuite
++ include
+
+ AM_CFLAGS = -Iproc
+ LDADD = ./proc/libprocps.la $(CYGWINFLAGS)
+--- a/configure.ac
++++ b/configure.ac
+@@ -256,8 +256,5 @@ AC_CHECK_FUNCS([__fpending alarm atexit
+
+ AC_CONFIG_FILES([Makefile
+ include/Makefile
+- man-po/Makefile
+- po/Makefile.in
+- proc/libprocps.pc
+- testsuite/Makefile])
++ proc/libprocps.pc])
+ AC_OUTPUT