aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-12-07 21:55:33 -0800
committerRosen Penev <rosenp@gmail.com>2020-12-10 01:50:28 -0800
commit7d3737f82a1316cbebbd8591865ff444a7697ba6 (patch)
treed2d99dbaedeb1116f06c6269ee327d561c93f3fb
parent5af59188f6819ee6467cd76e6f5101ba46996fbe (diff)
libgcrypt: fix config file
Change the prefix instead of each path. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libgcrypt/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/libs/libgcrypt/Makefile b/libs/libgcrypt/Makefile
index 955fc1074..e07b9e701 100644
--- a/libs/libgcrypt/Makefile
+++ b/libs/libgcrypt/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=libgcrypt
PKG_VERSION:=1.8.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://www.gnupg.org/ftp/gcrypt/libgcrypt/
@@ -59,9 +59,8 @@ define Build/InstallDev
$(CP) $(PKG_INSTALL_DIR)/usr/include/gcrypt*.h $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libgcrypt.{la,a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/share/aclocal/libgcrypt.m4 $(1)/usr/share/aclocal/
- $(SED) 's,^libdir=\"$$$${exec_prefix}/lib,libdir=\"$(STAGING_DIR)/usr/lib,g' $(1)/usr/bin/libgcrypt-config
- $(SED) 's,^includedir=\"$$$${prefix}/include/,includedir=\"$(STAGING_DIR)/usr/include/,g' $(1)/usr/bin/libgcrypt-config
- ln -sf $(STAGING_DIR)/usr/bin/libgcrypt-config $(2)/bin/
+ $(SED) 's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' $(1)/usr/bin/libgcrypt-config
+ $(LN) ../../usr/bin/libgcrypt-config $(2)/bin/libgcrypt-config
endef
define Package/libgcrypt/install