aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2021-03-01 12:22:38 +0100
committerFlorian Eckert <fe@dev.tdt.de>2021-03-01 12:23:43 +0100
commit7cfb282432dad52aca0c2c578b43a99da4f8522a (patch)
treed6e25404c13cc2c62f22221b6f89a6b621c42773
parent19ccf8a96fd04eacce9d3c85bbacf1f1831978ec (diff)
mwan3: disable DNS lookups for ping checks
By default, ping does a reverse DNS of the IP that you are pinging. When you have a network issue (such as when a link has just gone down and you haven't yet marked it down), this lookup can cause failures on tests for links that are still good. This option only works for iputils ping. For busybox the option is not evaluated, but it is accepted without throwing an error. Fixes: #14968 Fixes: #14924 Signed-off-by: Florian Eckert <fe@dev.tdt.de> Suggested-by: David Lang <david@lang.hm>
-rw-r--r--net/mwan3/Makefile2
-rwxr-xr-xnet/mwan3/files/usr/sbin/mwan3track4
2 files changed, 3 insertions, 3 deletions
diff --git a/net/mwan3/Makefile b/net/mwan3/Makefile
index 914844674..c8f551df2 100644
--- a/net/mwan3/Makefile
+++ b/net/mwan3/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mwan3
-PKG_VERSION:=2.10.6
+PKG_VERSION:=2.10.7
PKG_RELEASE:=1
PKG_MAINTAINER:=Florian Eckert <fe@dev.tdt.de>, \
Aaron Goodman <aaronjg@alumni.stanford.edu>
diff --git a/net/mwan3/files/usr/sbin/mwan3track b/net/mwan3/files/usr/sbin/mwan3track
index c6333198e..fd81f68c3 100755
--- a/net/mwan3/files/usr/sbin/mwan3track
+++ b/net/mwan3/files/usr/sbin/mwan3track
@@ -242,12 +242,12 @@ main() {
case "$track_method" in
ping)
if [ $check_quality -eq 0 ]; then
- WRAP $PING -c $count -W $timeout -s $size -t $max_ttl -q $track_ip &> /dev/null &
+ WRAP $PING -n -c $count -W $timeout -s $size -t $max_ttl -q $track_ip &> /dev/null &
TRACK_PID=$!
wait $TRACK_PID
result=$?
else
- WRAP $PING -c $count -W $timeout -s $size -t $max_ttl -q $track_ip 2>/dev/null > $TRACK_OUTPUT &
+ WRAP $PING -n -c $count -W $timeout -s $size -t $max_ttl -q $track_ip 2>/dev/null > $TRACK_OUTPUT &
TRACK_PID=$!
wait $TRACK_PID
ping_status=$?