aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorToke Høiland-Jørgensen <toke@redhat.com>2019-10-23 12:39:20 +0200
committerGitHub <noreply@github.com>2019-10-23 12:39:20 +0200
commit7ce4a5da3ae657fd15714baeebdfc14f9846cbc2 (patch)
tree81123a6c64624b12ad4841bf6bb2f77cbea1b416
parentcc7014d46079845e129b61fc08399c25cac58e58 (diff)
parent1653894091833a40125999025e4dbf60ed9bcb2f (diff)
Merge pull request #10340 from tohojo/acme-upd
A few updates to acme
2 files changed, 11 insertions, 5 deletions
diff --git a/net/acme/Makefile b/net/acme/Makefile
index 613d96ebf..fa70cdc78 100644
--- a/net/acme/Makefile
+++ b/net/acme/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=acme
-PKG_VERSION:=2.8.1
-PKG_RELEASE:=2
+PKG_VERSION:=2.8.3
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/Neilpang/acme.sh/tar.gz/$(PKG_VERSION)?
-PKG_HASH:=4fc55b2112058e563616893fefb56c5ff4895a7e6327e9f8416797fdc44d98e3
+PKG_HASH:=bdec71377a764919ac277e26d71ef7e24087f7f05171921888b70de6ab6e2cbc
PKG_BUILD_DIR:=$(BUILD_DIR)/acme.sh-$(PKG_VERSION)
PKG_MAINTAINER:=Toke Høiland-Jørgensen <toke@toke.dk>
diff --git a/net/acme/files/run.sh b/net/acme/files/run.sh
index b7a6f1899..3d25321d7 100644
--- a/net/acme/files/run.sh
+++ b/net/acme/files/run.sh
@@ -54,6 +54,12 @@ get_listeners() {
done
}
+run_acme()
+{
+ debug "Running acme.sh as '$ACME $@'"
+ $ACME "$@"
+}
+
pre_checks()
{
main_domain="$1"
@@ -218,7 +224,7 @@ issue_cert()
moved_staging=1
else
log "Found previous cert config. Issuing renew."
- $ACME --home "$STATE_DIR" --renew -d "$main_domain" $acme_args && ret=0 || ret=1
+ run_acme --home "$STATE_DIR" --renew -d "$main_domain" $acme_args && ret=0 || ret=1
post_checks
return $ret
fi
@@ -246,7 +252,7 @@ issue_cert()
acme_args="$acme_args --webroot $webroot"
fi
- if ! $ACME --home "$STATE_DIR" --issue $acme_args; then
+ if ! run_acme --home "$STATE_DIR" --issue $acme_args; then
failed_dir="$STATE_DIR/${main_domain}.failed-$(date +%s)"
err "Issuing cert for $main_domain failed. Moving state to $failed_dir"
[ -d "$STATE_DIR/$main_domain" ] && mv "$STATE_DIR/$main_domain" "$failed_dir"