aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNikos Mavrogiannopoulos <nmav@gnutls.org>2015-10-31 11:50:47 +0100
committerNikos Mavrogiannopoulos <nmav@gnutls.org>2015-10-31 11:52:47 +0100
commit7c9c18e7561a980a7395fd600de479246074b109 (patch)
treefeb86f01fb4f5c90a469c6608d4429c0ca9e0495
parentd56ae0e94e04f7ba0f081fb1c905a60115544fdf (diff)
ocserv: removed unecessary instructions and script
Signed-off-by: Nikos Mavrogiannopoulos <nmav@gnutls.org>
-rw-r--r--net/ocserv/Makefile1
-rw-r--r--net/ocserv/README3
-rwxr-xr-xnet/ocserv/files/ocserv-script11
3 files changed, 1 insertions, 14 deletions
diff --git a/net/ocserv/Makefile b/net/ocserv/Makefile
index 879142dcd..2f55d8d27 100644
--- a/net/ocserv/Makefile
+++ b/net/ocserv/Makefile
@@ -92,7 +92,6 @@ define Package/ocserv/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/ocpasswd $(1)/usr/bin/
$(INSTALL_BIN) $(PKG_BUILD_DIR)/src/occtl $(1)/usr/bin/
- $(INSTALL_BIN) ./files/ocserv-script $(1)/usr/bin/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/ocserv.init $(1)/etc/init.d/ocserv
$(INSTALL_DIR) $(1)/etc/ocserv
diff --git a/net/ocserv/README b/net/ocserv/README
index 9d000ccc8..d868872c9 100644
--- a/net/ocserv/README
+++ b/net/ocserv/README
@@ -18,7 +18,6 @@ config ocserv 'config'
option netmask '255.255.255.0'
option ipaddr '10.100.3.0'
option auth 'plain'
- option zone 'vpn'
option default_domain 'lan'
option compression '1'
option enable '1'
@@ -57,7 +56,7 @@ config interface 'vpn'
----/etc/config/firewall-----------------------------------------
config zone
option input 'ACCEPT'
- option forward 'REJECT'
+ option forward 'ACCEPT'
option output 'ACCEPT'
option name 'vpn'
option device 'vpns+'
diff --git a/net/ocserv/files/ocserv-script b/net/ocserv/files/ocserv-script
deleted file mode 100755
index 325198654..000000000
--- a/net/ocserv/files/ocserv-script
+++ /dev/null
@@ -1,11 +0,0 @@
-#!/bin/sh
-
-ZONE=`uci get ocserv.config.zone`
-
-if [ "$REASON" = "connect" ];then
- env -i ACTION=ifup INTERFACE="$ZONE" DEVICE=$DEVICE /sbin/hotplug-call "iface"
-else
- env -i ACTION=ifdown INTERFACE="$ZONE" DEVICE=$DEVICE /sbin/hotplug-call "iface"
-fi
-
-exit 0