aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2018-07-31 22:46:17 +0300
committerGitHub <noreply@github.com>2018-07-31 22:46:17 +0300
commit7c21db5fbcbf6e60f40224fb7f2552cbb3fd9155 (patch)
treefb10c66ec31f467a2c80a5fa7d2662bcb19dbf49
parent5c6d26f6a5d12e1f8d6f13093dc4b05008e7ff75 (diff)
parent062bd423e5583b37acb460a0461b00128ea8e678 (diff)
Merge pull request #6420 from micmac1/lighttpd-uclibc-iconv
lighttpd: fix uclibc build issue
-rw-r--r--net/lighttpd/Makefile14
1 files changed, 5 insertions, 9 deletions
diff --git a/net/lighttpd/Makefile b/net/lighttpd/Makefile
index 92d87b8e0..cb0ab7d7f 100644
--- a/net/lighttpd/Makefile
+++ b/net/lighttpd/Makefile
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2015 OpenWrt.org
+# Copyright (C) 2006-2018 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=lighttpd
PKG_VERSION:=1.4.49
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://download.lighttpd.net/lighttpd/releases-1.4.x
@@ -26,6 +26,8 @@ REBUILD_MODULES=authn_gssapi authn_ldap authn_mysql cml magnet mysql_vhost trigg
PKG_CONFIG_DEPENDS:=CONFIG_LIGHTTPD_SSL $(patsubst %,CONFIG_PACKAGE_lighttpd-mod-%,$(REBUILD_MODULES))
include $(INCLUDE_DIR)/package.mk
+# iconv is required for lighttpd's mysql plugin
+include $(INCLUDE_DIR)/nls.mk
define Package/lighttpd/Default
SUBMENU:=Web Servers/Proxies
@@ -92,7 +94,7 @@ else
CONFIGURE_ARGS+= --without-ldap
endif
-ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-authn_mysql),)
+ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-authn_mysql)$(CONFIG_PACKAGE_lighttpd-mod-mysql_vhost),)
CONFIGURE_ARGS+= --with-mysql
else
CONFIGURE_ARGS+= --without-mysql
@@ -110,12 +112,6 @@ else
CONFIGURE_ARGS+= --without-lua
endif
-ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-mysql_vhost),)
- CONFIGURE_ARGS+= --with-mysql
-else
- CONFIGURE_ARGS+= --without-mysql
-endif
-
#ifneq ($(SDK)$(CONFIG_PACKAGE_lighttpd-mod-cml)$(CONFIG_PACKAGE_lighttpd-mod-trigger_b4_dl),)
# CONFIGURE_ARGS+= --with-memcached
#else