aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2021-04-03 18:46:39 -0700
committerGitHub <noreply@github.com>2021-04-03 18:46:39 -0700
commit79f62459b3def0d196b55e2ff08bdd8906917450 (patch)
tree017bc2cdd110c3b789c334b407bea444ea663d72
parentbb181a18c1549c2df31d22e97444a479acad72ea (diff)
parentd303bd6aac986cf55b85b61fe4e4386a119e5332 (diff)
Merge pull request #15074 from ja-pa/python-greenlet
python-eventlet & python-greenlet: add new packages
-rw-r--r--lang/python/python-eventlet/Makefile50
-rw-r--r--lang/python/python-greenlet/Makefile44
2 files changed, 94 insertions, 0 deletions
diff --git a/lang/python/python-eventlet/Makefile b/lang/python/python-eventlet/Makefile
new file mode 100644
index 000000000..286a5f325
--- /dev/null
+++ b/lang/python/python-eventlet/Makefile
@@ -0,0 +1,50 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-eventlet
+PKG_VERSION:=0.30.2
+PKG_RELEASE:=1
+
+PYPI_NAME:=eventlet
+PKG_HASH:=1811b122d9a45eb5bafba092d36911bca825f835cb648a862bbf984030acff9d
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-eventlet
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Python concurrent networking library
+ URL:=https://eventlet.net/
+ DEPENDS:= \
+ +python3-light \
+ +python3-six \
+ +python3-dns \
+ +python3-greenlet \
+ +python3-distutils \
+ +python3-email \
+ +python3-logging \
+ +python3-openssl \
+ +python3-urllib
+endef
+
+define Package/python3-eventlet/description
+ Eventlet is a concurrent networking library for Python that
+ allows you to change how you run your code, not how you write it.
+endef
+
+$(eval $(call Py3Package,python3-eventlet))
+$(eval $(call BuildPackage,python3-eventlet))
+$(eval $(call BuildPackage,python3-eventlet-src))
diff --git a/lang/python/python-greenlet/Makefile b/lang/python/python-greenlet/Makefile
new file mode 100644
index 000000000..130037154
--- /dev/null
+++ b/lang/python/python-greenlet/Makefile
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2021 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-greenlet
+PKG_VERSION:=1.0.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=greenlet
+PKG_HASH:=719e169c79255816cdcf6dccd9ed2d089a72a9f6c42273aae12d55e8d35bdcf8
+
+PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec@nic.cz>
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-greenlet
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Lightweight coroutines for in-process concurrent programming
+ URL:=https://github.com/python-greenlet/greenlet
+ DEPENDS:= \
+ +python3-light \
+ +libstdcpp \
+ @!(arc||mips)
+endef
+
+define Package/python3-greenlet/description
+ The greenlet package is a spin-off of Stackless
+ a version of CPython that supports micro-threads called tasklets.
+endef
+
+$(eval $(call Py3Package,python3-greenlet))
+$(eval $(call BuildPackage,python3-greenlet))
+$(eval $(call BuildPackage,python3-greenlet-src))