aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDirk Neukirchen <dirkneukirchen@web.de>2015-06-15 11:45:13 +0200
committerDirk Neukirchen <dirkneukirchen@web.de>2015-08-19 11:19:50 +0200
commit79e2e32c275c8c91beae6ccc33c83887e64f2638 (patch)
tree12c7b29a510f8a4037c161872e895057b3796d0a
parentad39db848e72054e1ecfae787ef5f24b8d25a12a (diff)
mocp: fix build with gcc5
change in default CPP settings lead to build errors explicitly set flag to enable old behaviour Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de>
-rw-r--r--sound/mocp/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/sound/mocp/Makefile b/sound/mocp/Makefile
index d1917bfbe..bef28d26d 100644
--- a/sound/mocp/Makefile
+++ b/sound/mocp/Makefile
@@ -40,8 +40,9 @@ endef
TARGET_CFLAGS+=-D_GNU_SOURCE
-define Build/Configure
- $(call Build/Configure/Default, \
+TARGET_CPPFLAGS+=-P
+
+CONFIGURE_ARGS+= \
$(if $(CONFIG_BUILD_PATENTED),,--without-mp3) \
--enable-shared \
--disable-static \
@@ -53,8 +54,7 @@ define Build/Configure
--without-musepack \
--without-rcc \
$(if $(CONFIG_PACKAGE_libncursesw),--with-ncursesw --without-ncurses,--with-ncurses --without-ncursesw) \
- )
-endef
+ --with-bdb-dir="$(STAGING_DIR)/usr"
define Package/moc/install
$(INSTALL_DIR) $(1)/usr/bin