aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTed Hess <thess@kitschensync.net>2018-11-11 17:17:05 -0500
committerGitHub <noreply@github.com>2018-11-11 17:17:05 -0500
commit79928f9278e2561ff1a434db726acc2b9cb267ba (patch)
tree3e6e511fdfccb6e2b8d09c87f88ab5d63c7d1729
parent1e8829bb920d7d333fd2d3db1e6c8fe165437db5 (diff)
parentc44e1d43a36343564972b48809357fa7cef3fa5c (diff)
Merge pull request #7396 from thess/ffmpeg-x264
ffmpeg: Resolve libx264, BUILD_PATENTED anomalies
-rw-r--r--multimedia/ffmpeg/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index ab7bf478a..444c285fb 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=ffmpeg
PKG_VERSION:=3.2.12
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://ffmpeg.org/releases/
@@ -345,7 +345,7 @@ $(call Package/libffmpeg/Default)
DEPENDS+= +alsa-lib +PACKAGE_libopus:libopus \
+SOFT_FLOAT:shine \
+!SOFT_FLOAT:lame-lib \
- +!SOFT_FLOAT:libx264
+ +PACKAGE_libx264:libx264
VARIANT:=full
endef
@@ -488,15 +488,15 @@ ifeq ($(BUILD_VARIANT),full)
FFMPEG_CONFIGURE+= --enable-small
endif
FFMPEG_CONFIGURE+= $(if $(CONFIG_PACKAGE_lame-lib),--enable-libmp3lame)
- # x264 support and fdk-aac support can't coexist and be distributed.
- # Prioritize x264 over fdk-aac in default builds (maintain status-quo).
- ifneq ($(CONFIG_PACKAGE_libx264),)
- FFMPEG_CONFIGURE+= \
- --enable-gpl \
- --enable-libx264
- else
- FFMPEG_CONFIGURE+= $(if $(CONFIG_PACKAGE_fdk-aac),--enable-libfdk-aac)
- endif
+ endif
+ # x264 support and fdk-aac support can't coexist and be distributed.
+ # Prioritize x264 over fdk-aac in default builds (maintain status-quo).
+ ifneq ($(CONFIG_PACKAGE_libx264),)
+ FFMPEG_CONFIGURE+= \
+ --enable-gpl \
+ --enable-libx264
+ else
+ FFMPEG_CONFIGURE+= $(if $(CONFIG_PACKAGE_fdk-aac),--enable-libfdk-aac)
endif
endif
@@ -653,13 +653,11 @@ define Build/InstallDev/full
$(CP) $(PKG_INSTALL_DIR)/usr/include/lib{avcodec,avdevice,avfilter,avformat,avresample,avutil,swresample,swscale} $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avresample,avutil,swresample,swscale}.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/lib{avcodec,avdevice,avfilter,avformat,avresample,avutil,swresample,swscale}.pc $(1)/usr/lib/pkgconfig/
-ifneq ($(CONFIG_SOFT_FLOAT),y)
ifneq ($(CONFIG_PACKAGE_libx264),)
$(CP) $(PKG_INSTALL_DIR)/usr/include/libpostproc $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpostproc.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libpostproc.pc $(1)/usr/lib/pkgconfig/
endif
-endif
endef
define Build/InstallDev/mini
@@ -721,11 +719,9 @@ endef
define Package/libffmpeg-full/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{avcodec,avdevice,avfilter,avformat,avresample,avutil,swresample,swscale}.so.* $(1)/usr/lib/
-ifneq ($(CONFIG_SOFT_FLOAT),y)
ifneq ($(CONFIG_PACKAGE_libx264),)
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libpostproc.so.* $(1)/usr/lib/
endif
-endif
endef
define Package/libffmpeg-mini/install