aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStan Grishin <stangri@melmac.ca>2022-11-02 00:48:14 -0700
committerGitHub <noreply@github.com>2022-11-02 00:48:14 -0700
commit7960285c3301532e8c464fb06260ce14ae4357a0 (patch)
treed0f50ac282258ff2243461a0042b13af9c5ab571
parenta5913d51c7024b9f62e213541812a0bdd67e2984 (diff)
parent9c78e10030e00956cb66d11cb2149eff69c9a494 (diff)
Merge pull request #19770 from stangri/master-curl
curl: bugfix: building as selected package doesn't break build
-rw-r--r--net/curl/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/net/curl/Makefile b/net/curl/Makefile
index 6b96d739b..1b19a0318 100644
--- a/net/curl/Makefile
+++ b/net/curl/Makefile
@@ -124,6 +124,7 @@ CONFIGURE_ARGS += \
\
$(call autoconf_bool,CONFIG_IPV6,ipv6) \
\
+ $(if $(CONFIG_LIBCURL_WOLFSSL)$(CONFIG_LIBCURL_GNUTLS)$(CONFIG_LIBCURL_OPENSSL)$(CONFIG_LIBCURL_MBEDTLS),,--without-ssl) \
$(if $(CONFIG_LIBCURL_WOLFSSL),--with-wolfssl="$(STAGING_DIR)/usr",--without-wolfssl) \
$(if $(CONFIG_LIBCURL_GNUTLS),--with-gnutls="$(STAGING_DIR)/usr",--without-gnutls) \
$(if $(CONFIG_LIBCURL_OPENSSL),--with-openssl="$(STAGING_DIR)/usr",--without-openssl) \