aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2017-05-17 22:36:18 +0300
committerGitHub <noreply@github.com>2017-05-17 22:36:18 +0300
commit794afe759961b25745f8c243f1bf9c6973426abd (patch)
tree08d233f22d26a3a7d231cbb081b55dc14148e87a
parent64d62b15b6644823f07bfc9e5b557f36a58dbe74 (diff)
parent1eeea0530762ebbeededd0e56528cb8901c64139 (diff)
Merge pull request #4341 from zx2c4/wg-psk-change
wireguard: update snapshot version to 0.0.20170517
-rw-r--r--net/wireguard/Makefile4
-rw-r--r--net/wireguard/files/wireguard.sh11
2 files changed, 7 insertions, 8 deletions
diff --git a/net/wireguard/Makefile b/net/wireguard/Makefile
index cf0a5715b..a83249667 100644
--- a/net/wireguard/Makefile
+++ b/net/wireguard/Makefile
@@ -11,12 +11,12 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=wireguard
-PKG_VERSION:=0.0.20170421
+PKG_VERSION:=0.0.20170517
PKG_RELEASE:=1
PKG_SOURCE:=WireGuard-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=https://git.zx2c4.com/WireGuard/snapshot/
-PKG_HASH:=03c82af774224cd171d000ee4a519b5e474cc6842ac04967773cf77b26750000
+PKG_HASH:=7303e973654a3585039f4789e89a562f807f0d6010c7787b9b69ca72aa7a6908
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
diff --git a/net/wireguard/files/wireguard.sh b/net/wireguard/files/wireguard.sh
index 638ddd922..d862c1021 100644
--- a/net/wireguard/files/wireguard.sh
+++ b/net/wireguard/files/wireguard.sh
@@ -21,7 +21,6 @@ proto_wireguard_init_config() {
proto_config_add_string "private_key"
proto_config_add_int "listen_port"
proto_config_add_int "mtu"
- proto_config_add_string "preshared_key"
proto_config_add_string "fwmark"
available=1
no_proto_task=1
@@ -32,6 +31,7 @@ proto_wireguard_setup_peer() {
local peer_config="$1"
local public_key
+ local preshared_key
local allowed_ips
local route_allowed_ips
local endpoint_host
@@ -39,6 +39,7 @@ proto_wireguard_setup_peer() {
local persistent_keepalive
config_get public_key "${peer_config}" "public_key"
+ config_get preshared_key "${peer_config}" "preshared_key"
config_get allowed_ips "${peer_config}" "allowed_ips"
config_get_bool route_allowed_ips "${peer_config}" "route_allowed_ips" 0
config_get endpoint_host "${peer_config}" "endpoint_host"
@@ -48,6 +49,9 @@ proto_wireguard_setup_peer() {
# peer configuration
echo "[Peer]" >> "${wg_cfg}"
echo "PublicKey=${public_key}" >> "${wg_cfg}"
+ if [ "${preshared_key}" ]; then
+ echo "PresharedKey=${preshared_key}" >> "${wg_cfg}"
+ fi
for allowed_ip in $allowed_ips; do
echo "AllowedIPs=${allowed_ip}" >> "${wg_cfg}"
done
@@ -95,7 +99,6 @@ proto_wireguard_setup() {
local private_key
local listen_port
local mtu
- local preshared_key
# load configuration
config_load network
@@ -103,7 +106,6 @@ proto_wireguard_setup() {
config_get listen_port "${config}" "listen_port"
config_get addresses "${config}" "addresses"
config_get mtu "${config}" "mtu"
- config_get preshared_key "${config}" "preshared_key"
config_get fwmark "${config}" "fwmark"
# create interface
@@ -124,9 +126,6 @@ proto_wireguard_setup() {
if [ "${listen_port}" ]; then
echo "ListenPort=${listen_port}" >> "${wg_cfg}"
fi
- if [ "${preshared_key}" ]; then
- echo "PresharedKey=${preshared_key}" >> "${wg_cfg}"
- fi
if [ "${fwmark}" ]; then
echo "FwMark=${fwmark}" >> "${wg_cfg}"
fi