aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2023-10-03 22:59:58 +0800
committerRosen Penev <rosenp@gmail.com>2023-10-03 16:55:10 -0700
commit78bcdd0fd1291a1a02e0d73e43c28e04f36d507d (patch)
treed5d1083e319170d4fd132c190dfc2a1555f3184b
parent00cad2980cc7707f662acb1fa2a51c4e4fc331d9 (diff)
python-packaging: Update to 23.2
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-packaging/Makefile6
-rw-r--r--lang/python/python-packaging/test.sh11
2 files changed, 14 insertions, 3 deletions
diff --git a/lang/python/python-packaging/Makefile b/lang/python/python-packaging/Makefile
index cb4e0d039..1bec008be 100644
--- a/lang/python/python-packaging/Makefile
+++ b/lang/python/python-packaging/Makefile
@@ -7,11 +7,11 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-packaging
-PKG_VERSION:=23.1
+PKG_VERSION:=23.2
PKG_RELEASE:=1
PYPI_NAME:=packaging
-PKG_HASH:=a392980d2b6cffa644431898be54b0045151319d1e7ec34f0cfed48767dd334f
+PKG_HASH:=048fb0e9405036518eaaf48a55953c750c11e1a1b68e0dd1a9d62ed0c092cfc5
PKG_MAINTAINER:=Jan Pavlinec <jan.pavlinec1@gmail.com>, Jeffery To <jeffery.to@gmail.com>
PKG_LICENSE:=Apache-2.0 BSD-2-Clause
@@ -32,7 +32,7 @@ define Package/python3-packaging
SUBMENU:=Python
TITLE:=Core utilities for Python packages
URL:=https://github.com/pypa/packaging
- DEPENDS:=+python3-light +python3-logging +python3-urllib
+ DEPENDS:=+python3-light +python3-email +python3-logging +python3-urllib
endef
define Package/python3-packaging/description
diff --git a/lang/python/python-packaging/test.sh b/lang/python/python-packaging/test.sh
new file mode 100644
index 000000000..4fc13bae8
--- /dev/null
+++ b/lang/python/python-packaging/test.sh
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+[ "$1" = python3-packaging ] || exit 0
+
+python3 - << EOF
+import sys
+from packaging.version import Version, parse
+v1 = parse("1.0a5")
+v2 = Version("1.0")
+sys.exit(0 if v1 < v2 else 1)
+EOF