aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOthmar Truniger <github@truniger.ch>2015-06-27 21:49:25 +0200
committerOthmar Truniger <github@truniger.ch>2015-06-27 21:49:25 +0200
commit77cee81ca0c907cbf96dd81757c341d8698f5281 (patch)
tree85e3cdfbaf133f6852f25941e446b8dc88cfc012
parent474a5bf7955646c7c862948f99f50fbfd2e4f966 (diff)
knxd: fix musl compatibility
Signed-off-by: Othmar Truniger <github@truniger.ch>
-rw-r--r--net/knxd/Makefile4
-rw-r--r--net/knxd/patches/0100-musl-compat10
2 files changed, 12 insertions, 2 deletions
diff --git a/net/knxd/Makefile b/net/knxd/Makefile
index cc7f81d41..238840629 100644
--- a/net/knxd/Makefile
+++ b/net/knxd/Makefile
@@ -11,12 +11,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=knxd
-PKG_VERSION=2015-06-02-$(PKG_SOURCE_VERSION)
+PKG_VERSION=2015-06-27-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/knxd/knxd.git
-PKG_SOURCE_VERSION:=3d3b1a5e8112397d297625d673a2a94507f9ebce
+PKG_SOURCE_VERSION:=50e7f6e6bfa13c2b6140b0f76aaa70234bf44b1d
PKG_SOURCE_SUBDIR:=$(PKG_NAME)
PKG_SOURCE:=$(PKG_NAME)-$(PKG_SOURCE_VERSION).tar.gz
diff --git a/net/knxd/patches/0100-musl-compat b/net/knxd/patches/0100-musl-compat
new file mode 100644
index 000000000..0c2a09b24
--- /dev/null
+++ b/net/knxd/patches/0100-musl-compat
@@ -0,0 +1,10 @@
+--- a/src/examples/common.h 2015-06-27 15:20:15.266563893 +0200
++++ b/src/examples/common.h 2015-06-27 15:23:09.406457392 +0200
+@@ -20,6 +20,7 @@
+ #include <stdlib.h>
+ #include <errno.h>
+ #include <unistd.h>
++#include <sys/select.h>
+ #include "eibclient.h"
+
+ /** unsigned char*/