aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHannu Nyman <hannu.nyman@iki.fi>2021-09-27 21:48:03 +0300
committerRosen Penev <rosenp@gmail.com>2021-09-27 22:20:12 -0700
commit7778661b0861290fbb0e9bf845f4007cc845b486 (patch)
treec65e419118036cd6d4ac2c8b48657dbdac9e313b
parentbf40d06f3d78377f500dc2d4150e86688b5e7d8d (diff)
fontconfig: avoid compilation problem (on Ubuntu)
Partially revert an upstream commit to avoid build breakage on Ubuntu. Refrerence to discussion starting at https://github.com/openwrt/packages/pull/16726#issuecomment-927309052 Upstream commit: https://gitlab.freedesktop.org/fontconfig/fontconfig/-/commit/ae9ac2a1bfb6fa800b99791b6fc36711dd0c1fbc meson: fix cross-compilation issues with gperf header file preprocessing Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
-rw-r--r--utils/fontconfig/patches/001-revert-upstream-meson-commit.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch b/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch
new file mode 100644
index 000000000..bcd7ce8c8
--- /dev/null
+++ b/utils/fontconfig/patches/001-revert-upstream-meson-commit.patch
@@ -0,0 +1,26 @@
+Revert partially the upstream commit ae9ac2a1
+
+ Subject: [PATCH] meson: fix cross-compilation issues with gperf header file preprocessing
+
+ Pass c_args to the compiler when preprocessing the gperf header file,
+ they might contain important bits without which compilation/preprocessing
+ might fail (e.g. with clang on Android). cc.cmd_array() does not include
+ the c_args and we can't easily look them up from the meson.build file, so
+ we have to retrieve from the introspection info.
+
+ This is basically the Meson equivalent to commit 57103773.
+
+Revert the host_cargs related part of the patch
+
+
+--- a/src/cutout.py
++++ b/src/cutout.py
+@@ -24,7 +24,7 @@ if __name__== '__main__':
+ break
+
+ cpp = args[1]
+- ret = subprocess.run(cpp + host_cargs + [args[0].input], stdout=subprocess.PIPE, check=True)
++ ret = subprocess.run(cpp + [args[0].input], stdout=subprocess.PIPE, check=True)
+
+ stdout = ret.stdout.decode('utf8')
+