aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRichard Kunze <richard.kunze@web.de>2014-11-16 10:47:10 +0100
committerRichard Kunze <richard.kunze@web.de>2014-11-16 10:47:10 +0100
commit773f8d4b1350d85200262758c6f89557c3d7c185 (patch)
tree9c17a827214133142015e183e3d1e6bee183fe17
parent7c94f6150650828f0c65527d0b6b0466f926a713 (diff)
sispmctl: fix compilation error with musl
Unpatched compile fails because <sys/types.h> is not included in <usb.h> (provided by "libusb-compat") and consequently the 'u_int*_t' types are not found. This should probably better be fixed in the core "libusb-compat" package instead. Signed-off-by: Richard Kunze <richard.kunze@web.de>
-rw-r--r--utils/sispmctl/Makefile1
-rw-r--r--utils/sispmctl/patches/001-fix-includes.patch25
2 files changed, 26 insertions, 0 deletions
diff --git a/utils/sispmctl/Makefile b/utils/sispmctl/Makefile
index 87e15f58f..ad6c1e352 100644
--- a/utils/sispmctl/Makefile
+++ b/utils/sispmctl/Makefile
@@ -43,6 +43,7 @@ define Package/sispmctl/description
multiple SIS-PM devices, too.
endef
+TARGET_CFLAGS += -D_GNU_SOURCE
CONFIGURE_ARGS += \
--enable-webless \
--disable-dependency-tracking
diff --git a/utils/sispmctl/patches/001-fix-includes.patch b/utils/sispmctl/patches/001-fix-includes.patch
new file mode 100644
index 000000000..218e22e1c
--- /dev/null
+++ b/utils/sispmctl/patches/001-fix-includes.patch
@@ -0,0 +1,25 @@
+--- a/src/sispm_ctl.c
++++ b/src/sispm_ctl.c
+@@ -33,6 +33,7 @@
+ #include <stdlib.h>
+ #include <unistd.h>
+ #include <time.h>
++#include <sys/types.h>
+ #include <usb.h>
+ #include <assert.h>
+ #include "sispm_ctl.h"
+--- a/src/main.c
++++ b/src/main.c
+@@ -34,11 +34,11 @@
+ #define __USE_XOPEN
+ #include <time.h>
+ #include <signal.h>
+-#include <usb.h>
+ #include <assert.h>
+ #include <getopt.h>
+ #include <sys/types.h>
+ #include <sys/socket.h>
++#include <usb.h>
+
+ #include <fcntl.h>
+