aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeffery To <jeffery.to@gmail.com>2018-06-25 02:30:39 +0800
committerJeffery To <jeffery.to@gmail.com>2018-06-25 02:30:39 +0800
commit76ccf6c556f514519c1a1e9b6c0de1d999abea2b (patch)
treea556e4fa0f09a4b7a89944309606f5fa3311ff27
parent6e0c99740553235bf059842fa6ca8a8e66be5b95 (diff)
python-hyperlink: update to 18.0.0
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
-rw-r--r--lang/python/python-hyperlink/Makefile12
1 files changed, 8 insertions, 4 deletions
diff --git a/lang/python/python-hyperlink/Makefile b/lang/python/python-hyperlink/Makefile
index 7f1d24138..36613abc1 100644
--- a/lang/python/python-hyperlink/Makefile
+++ b/lang/python/python-hyperlink/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=python-hyperlink
-PKG_VERSION:=17.3.1
+PKG_VERSION:=18.0.0
PKG_RELEASE:=1
PKG_SOURCE:=hyperlink-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/h/hyperlink
-PKG_HASH:=bc4ffdbde9bdad204d507bd8f554f16bba82dd356f6130cb16f41422909c33bc
+PKG_HASH:=f01b4ff744f14bc5d0a22a6b9f1525ab7d6312cb0ff967f59414bbac52f0a306
PKG_BUILD_DIR:=$(BUILD_DIR)/$(BUILD_VARIANT)-hyperlink-$(PKG_VERSION)
@@ -37,14 +37,18 @@ endef
define Package/python-hyperlink
$(call Package/python-hyperlink/Default)
TITLE:=Pure-Python immutable URLs
- DEPENDS:=+PACKAGE_python-hyperlink:python-light
+ DEPENDS:= \
+ +PACKAGE_python-hyperlink:python-light \
+ +PACKAGE_python-hyperlink:python-idna
VARIANT:=python
endef
define Package/python3-hyperlink
$(call Package/python-hyperlink/Default)
TITLE:=Pure-Python immutable URLs
- DEPENDS:=+PACKAGE_python3-hyperlink:python3-light
+ DEPENDS:= \
+ +PACKAGE_python3-hyperlink:python3-light \
+ +PACKAGE_python3-hyperlink:python3-idna
VARIANT:=python3
endef