aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2015-06-25 14:49:05 +0200
committerJo-Philipp Wich <jow@openwrt.org>2015-06-25 14:49:52 +0200
commit757de70511761ece54f38a70759382ebefb15c59 (patch)
tree398c28d8a5ee3a62813dc91572921fd20f89baaf
parent07c0677b7b96cc69109b8dda9cebd01e62aa2f26 (diff)
usb: fix musl compatibility
Replace the nonstandard `SIGCLD` signal name with the proper `SIGCHLD` spelling as the `SIGCLD` alias is not provided by musl. Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
-rw-r--r--net/usbip/Makefile2
-rw-r--r--net/usbip/patches-2.0/100-musl-compat.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/net/usbip/Makefile b/net/usbip/Makefile
index 8aa0df0eb..49130574f 100644
--- a/net/usbip/Makefile
+++ b/net/usbip/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=usbip
-PKG_RELEASE:=4
+PKG_RELEASE:=5
PKG_LICENSE:=GPL-2.0
# Since kernel 2.6.39.1 userspace tools are inside the kernel tree
diff --git a/net/usbip/patches-2.0/100-musl-compat.patch b/net/usbip/patches-2.0/100-musl-compat.patch
new file mode 100644
index 000000000..a64678cb8
--- /dev/null
+++ b/net/usbip/patches-2.0/100-musl-compat.patch
@@ -0,0 +1,11 @@
+--- a/src/usbipd.c
++++ b/src/usbipd.c
+@@ -453,7 +453,7 @@ static void set_signal(void)
+ sigaction(SIGTERM, &act, NULL);
+ sigaction(SIGINT, &act, NULL);
+ act.sa_handler = SIG_IGN;
+- sigaction(SIGCLD, &act, NULL);
++ sigaction(SIGCHLD, &act, NULL);
+ }
+
+ static const char *pid_file;