aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-02-26 20:17:03 -0800
committerRosen Penev <rosenp@gmail.com>2020-02-27 17:02:59 -0800
commit7518849bdab3fbf646e67938a9454ac90031a0d3 (patch)
tree4dd9ce309d7435f41fd3d632434d67d254e3cb0b
parent355d8b1388fa3cb238c1e2e4364470470805ea69 (diff)
upmpdcli: link against libm under glibc
Fixes compilation. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--sound/upmpdcli/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/sound/upmpdcli/Makefile b/sound/upmpdcli/Makefile
index a89f8a0a6..9cc15bdf4 100644
--- a/sound/upmpdcli/Makefile
+++ b/sound/upmpdcli/Makefile
@@ -42,6 +42,8 @@ define Package/upmpdcli/config
source "$(SOURCE)/Config.in"
endef
+TARGET_LDFLAGS += $(if $(CONFIG_USE_GLIBC),-lm)
+
define Package/upmpdcli/install
$(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/upmpdcli.conf $(1)/etc/