aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Čermák <jan.cermak@nic.cz>2015-07-02 17:57:13 +0200
committerJan Čermák <jan.cermak@nic.cz>2015-07-02 18:19:09 +0200
commit73244f09ecf65e1722cfa10529f6c966f5fa8575 (patch)
treed6d78a177624fd7d4d04a0c480658389609a9132
parent2dbf4507c3253b36c43b874a7e4e9e44d994ca57 (diff)
python: fix patch removing multiarch support for host python
Patch removing multiarch paths from build should be applied only when Python is built for target, but not for host. When the paths are removed during host build, host python throws some ugly errors when importing some hashlib modules. Also it reports that modules crypt and nis failed to build (tested on Ubuntu 14.04 host). Signed-off-by: Jan Čermák <jan.cermak@nic.cz>
-rw-r--r--lang/python/Makefile2
-rw-r--r--lang/python/patches/006-remove-debian-multiarch-support.patch6
2 files changed, 5 insertions, 3 deletions
diff --git a/lang/python/Makefile b/lang/python/Makefile
index 133bab0d9..0caa92ba2 100644
--- a/lang/python/Makefile
+++ b/lang/python/Makefile
@@ -12,7 +12,7 @@ include ./files/python-package.mk
PKG_NAME:=python
PKG_VERSION:=$(PYTHON_VERSION).$(PYTHON_VERSION_MICRO)
-PKG_RELEASE:=5
+PKG_RELEASE:=6
PKG_SOURCE:=Python-$(PKG_VERSION).tar.xz
PKG_SOURCE_URL:=http://www.python.org/ftp/python/$(PKG_VERSION)
diff --git a/lang/python/patches/006-remove-debian-multiarch-support.patch b/lang/python/patches/006-remove-debian-multiarch-support.patch
index 52d52b94e..01aa924ab 100644
--- a/lang/python/patches/006-remove-debian-multiarch-support.patch
+++ b/lang/python/patches/006-remove-debian-multiarch-support.patch
@@ -1,12 +1,14 @@
diff --git a/setup.py b/setup.py
-index 7868b7b..9ae0ef2 100644
+index 1d1ae72..511aed5 100644
--- a/setup.py
+++ b/setup.py
-@@ -444,7 +444,6 @@ class PyBuildExt(build_ext):
+@@ -444,7 +444,8 @@ class PyBuildExt(build_ext):
add_dir_to_list(self.compiler.include_dirs, '/usr/local/include')
if cross_compiling:
self.add_gcc_paths()
- self.add_multiarch_paths()
++ else:
++ self.add_multiarch_paths()
# Add paths specified in the environment variables LDFLAGS and
# CPPFLAGS for header and library files.