aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-19 22:14:10 -0700
committerRosen Penev <rosenp@gmail.com>2020-05-19 22:14:10 -0700
commit71975d68a426b65f0dc2fc0c8ea5b593cffdaa9a (patch)
treeddcd9b9da116567594f3eefb8137141f99e4bafc
parent64926ff60708fcee51e170872ce0fe2310b47449 (diff)
cifs-utils: fix compilation
Now that libcap-ng is in the tree, cifs-utils is picking it up. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--net/cifs-utils/Makefile5
1 files changed, 4 insertions, 1 deletions
diff --git a/net/cifs-utils/Makefile b/net/cifs-utils/Makefile
index 03f5acac5..ae6a4d8ed 100644
--- a/net/cifs-utils/Makefile
+++ b/net/cifs-utils/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=cifs-utils
PKG_VERSION:=6.10
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=https://download.samba.org/pub/linux-cifs/cifs-utils/
@@ -54,6 +54,9 @@ CONFIGURE_ARGS += \
--disable-man \
--without-libcap
+CONFIGURE_ARGS += \
+ ac_cv_lib_cap_ng_capng_clear=no
+
TARGET_CFLAGS += $(FPIC) -ffunction-sections -flto
TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed