aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Pavlinec <jan.pavlinec@nic.cz>2020-08-28 14:13:39 +0200
committerRosen Penev <rosenp@gmail.com>2020-08-31 07:05:12 -0700
commit7049b06130be97b6ef0c958be04c46bb5e850d37 (patch)
tree32e6956824144f454b3885d5d4f0b873dd5b4051
parentee226f1ff2c031e6846b4ecbcc6cecc000d7d6fd (diff)
autossh: switch to procd
Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
-rw-r--r--net/autossh/Makefile2
-rw-r--r--net/autossh/files/autossh.init20
2 files changed, 9 insertions, 13 deletions
diff --git a/net/autossh/Makefile b/net/autossh/Makefile
index a483991a1..78dc90eca 100644
--- a/net/autossh/Makefile
+++ b/net/autossh/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=autossh
PKG_VERSION:=1.4g
-PKG_RELEASE:=1
+PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tgz
PKG_SOURCE_URL:=https://www.harding.motd.ca/autossh/
diff --git a/net/autossh/files/autossh.init b/net/autossh/files/autossh.init
index e21b3910b..f73e41573 100644
--- a/net/autossh/files/autossh.init
+++ b/net/autossh/files/autossh.init
@@ -1,6 +1,7 @@
#!/bin/sh /etc/rc.common
# Copyright (C) 2007-2011 OpenWrt.org
+USE_PROCD=1
START=80
start_instance() {
@@ -14,20 +15,15 @@ start_instance() {
[ "$enabled" = 1 ] || exit 0
- export AUTOSSH_GATETIME="${gatetime:-30}"
- export AUTOSSH_POLL="${poll:-600}"
- service_start /usr/sbin/autossh -M ${monitorport:-20000} -f ${ssh}
+ procd_open_instance
+ procd_set_param command /usr/sbin/autossh -M ${monitorport:-20000} ${ssh}
+ procd_set_param respawn ${respawn_threshold:-3600} ${respawn_timeout:-5} ${respawn_retry:-5}
+ procd_set_param env AUTOSSH_GATETIME="${gatetime:-30}"
+ procd_set_param env AUTOSSH_POLL="${poll:-600}"
+ procd_close_instance
}
-boot() {
- return
-}
-
-start() {
+start_service() {
config_load 'autossh'
config_foreach start_instance 'autossh'
}
-
-stop() {
- service_stop /usr/sbin/autossh
-}