aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetko Bordjukov <bordjukov@gmail.com>2015-05-11 18:38:51 +0300
committerPetko Bordjukov <bordjukov@gmail.com>2015-05-13 01:51:14 +0300
commit6e96e4532a944a68f0bc179d17f580791fdb2134 (patch)
tree559c3dbe02a1e5db6a72b7f2e42eec3db6f5331b
parent5e3d7a8b96da04a1dbe94f9ccc1be7254bd93f6a (diff)
upmpdcli: Bump version to 0.11.0
upmpdcli 0.11 mainly improves on the Songcast support, in complement with the changes in sc2mpd. Especially, it now includes an utility (scctl) and web interface to set up multi-room Songcast. Signed-off-by: Petko Bordjukov <bordjukov@gmail.com>
-rw-r--r--sound/upmpdcli/Config.in17
-rw-r--r--sound/upmpdcli/Makefile19
2 files changed, 32 insertions, 4 deletions
diff --git a/sound/upmpdcli/Config.in b/sound/upmpdcli/Config.in
new file mode 100644
index 000000000..fe3272296
--- /dev/null
+++ b/sound/upmpdcli/Config.in
@@ -0,0 +1,17 @@
+config PACKAGE_UPMPDCLI_SCCTL
+ bool "scctl command for configuring SongCast receivers"
+ default no
+ depends on PACKAGE_upmpdcli
+ help
+ Installs the scctl command. See the following link for more info:
+ http://www.lesbonscomptes.com/upmpdcli/scmulti.html
+
+config PACKAGE_UPMPDCLI_SC_WEB_INTERFACE
+ bool "SongCast web server and associated files (depends on python)"
+ default no
+ depends on PACKAGE_upmpdcli
+ select PACKAGE_python
+ select PACKAGE_UPMPDCLI_SCCTL
+ help
+ Installs the SongCast web interface and web server. See the following
+ link for more info: http://www.lesbonscomptes.com/upmpdcli/scmulti.html
diff --git a/sound/upmpdcli/Makefile b/sound/upmpdcli/Makefile
index 385a96bee..42b98fa73 100644
--- a/sound/upmpdcli/Makefile
+++ b/sound/upmpdcli/Makefile
@@ -8,12 +8,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=upmpdcli
-PKG_VERSION:=0.9.0
-PKG_RELEASE:=2
+PKG_VERSION:=0.11.0
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://www.lesbonscomptes.com/upmpdcli/downloads
-PKG_MD5SUM:=0e7b86037f19ea3a08067409af6f6902
+PKG_MD5SUM:=40eb2a1988ca367a690fb2506e0f73c1
PKG_MAINTAINER:=Petko Bordjukov <bordjukov@gmail.com>
PKG_LICENSE:=GPL-2.0
PKG_LICENSE_FILES:=COPYING
@@ -29,12 +29,17 @@ define Package/upmpdcli
DEPENDS+= +libupnpp +libmpdclient
TITLE:=A UPnP front-end to MPD, the Music Player Daemon
USERID:=upmpdcli=89:upmpdcli=89
+ MENU:=1
endef
define Package/upmpdcli/description
upmpdcli implements an UPnP Media Renderer, using MPD to perform the real work.
endef
+define Package/upmpdcli/config
+ source "$(SOURCE)/Config.in"
+endef
+
define Package/upmpdcli/install
$(INSTALL_DIR) $(1)/etc
$(INSTALL_CONF) $(PKG_INSTALL_DIR)/etc/upmpdcli.conf $(1)/etc/
@@ -42,8 +47,14 @@ define Package/upmpdcli/install
$(INSTALL_CONF) ./files/upmpdcli.config $(1)/etc/config/upmpdcli
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/upmpdcli $(1)/usr/bin/
+ifeq ($(CONFIG_PACKAGE_UPMPDCLI_SCCTL),y)
+ $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/scctl $(1)/usr/bin/
+endif
$(INSTALL_DIR) $(1)/usr/share/upmpdcli
- $(INSTALL_DATA) $(PKG_INSTALL_DIR)/usr/share/upmpdcli/* $(1)/usr/share/upmpdcli/
+ifneq ($(CONFIG_PACKAGE_UPMPDCLI_SC_WEB_INTERFACE),y)
+ $(RM) -rf $(PKG_INSTALL_DIR)/usr/share/upmpdcli/web
+endif
+ $(CP) -r $(PKG_INSTALL_DIR)/usr/share/upmpdcli $(1)/usr/share/
$(INSTALL_DATA) ./files/upmpdcli.png $(1)/usr/share/upmpdcli/
$(INSTALL_DIR) $(1)/etc/init.d
$(INSTALL_BIN) ./files/upmpdcli.init $(1)/etc/init.d/upmpdcli