aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandru Ardelean <ardeleanalex@gmail.com>2017-01-04 11:25:47 +0200
committerAlexandru Ardelean <ardeleanalex@gmail.com>2017-01-04 15:08:37 +0200
commit6d9137048bb8494dd306b54b34134c8302a2cd56 (patch)
treebf416f863bba9d18f21f463cff1b6ad64b7add68
parentbb2f8fa8ed9ea2b4ae8ab0a59ea67c913c8c4d60 (diff)
python: simplify/unify default build rules for python packages
Most python packages use the same build rules & vars. So, adding them in python-package.mk. Also, preparing for using VARIANTs for python/python3 packages. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
-rw-r--r--lang/python/files/python-host.mk16
-rw-r--r--lang/python/files/python-package.mk35
2 files changed, 35 insertions, 16 deletions
diff --git a/lang/python/files/python-host.mk b/lang/python/files/python-host.mk
index dc0c0c049..7833a0c73 100644
--- a/lang/python/files/python-host.mk
+++ b/lang/python/files/python-host.mk
@@ -77,4 +77,20 @@ define Build/Compile/HostPyMod
$(3))
endef
+define HostPy/Compile/Default
+ $(call Build/Compile/HostPyMod,,\
+ install --root="$(HOST_BUILD_PREFIX)" --prefix="" \
+ --single-version-externally-managed \
+ )
+endef
+
+ifeq ($(BUILD_VARIANT),python)
+define Host/Compile
+ $(call HostPy/Compile/Default)
+endef
+
+define Host/Install
+endef
+endif # python
+
endif # __python_host_mk_inc
diff --git a/lang/python/files/python-package.mk b/lang/python/files/python-package.mk
index 2a2e371c3..d0818a64c 100644
--- a/lang/python/files/python-package.mk
+++ b/lang/python/files/python-package.mk
@@ -41,6 +41,15 @@ define PyPackage
endef
endif
+ ifndef PyPackage/$(1)/install
+ define PyPackage/$(1)/install
+ if [ -d $(PKG_INSTALL_DIR)/usr/bin ]; then \
+ $(INSTALL_DIR) $$(1)/usr/bin \
+ $(CP) $(PKG_INSTALL_DIR)/usr/bin/* $$(1)/usr/bin/
+ fi
+ endef
+ endif
+
$(call shexport,PyPackage/$(1)/filespec)
define Package/$(1)/install
@@ -115,21 +124,15 @@ define Build/Compile/PyMod
find $(PKG_INSTALL_DIR) -name "*\.pyc" -o -name "*\.pyo" -o -name "*\.exe" | xargs rm -f
endef
-define PyMod/Default
- define Build/Compile
- $$(call Build/Compile/PyMod,,install --prefix=/usr --root=$(PKG_INSTALL_DIR))
- endef
-
- define Package/$(PKG_NAME)/install
- $(INSTALL_DIR) $$(1)$(PYTHON_PKG_DIR) $$(1)/usr/bin
- if [ -d $(PKG_INSTALL_DIR)/usr/bin ]; then find $(PKG_INSTALL_DIR)/usr/bin -mindepth 1 -maxdepth 1 -type f -exec $(CP) \{\} $$(1)/usr/bin/ \; ; fi
- find $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR) -mindepth 1 -maxdepth 1 \( -type f -o -type d \) -exec $(CP) \{\} $$(1)$(PYTHON_PKG_DIR)/ \;
- endef
-
- define Build/InstallDev
- $(INSTALL_DIR) $$(1)/usr/bin $$(1)$(PYTHON_PKG_DIR)
- if [ -d $(PKG_INSTALL_DIR)/usr/bin ]; then find $(PKG_INSTALL_DIR)/usr/bin -mindepth 1 -maxdepth 1 -type f -exec $(CP) \{\} $$(1)/usr/bin/ \; ; fi
- find $(PKG_INSTALL_DIR)$(PYTHON_PKG_DIR) -mindepth 1 -maxdepth 1 \( -type f -o -type d \) -exec $(CP) \{\} $$(1)$(PYTHON_PKG_DIR)/ \;
- endef
+define PyBuild/Compile/Default
+ $(call Build/Compile/PyMod,, \
+ install --prefix="/usr" --root="$(PKG_INSTALL_DIR)" \
+ --single-version-externally-managed \
+ )
endef
+ifeq ($(BUILD_VARIANT),python)
+define Build/Compile
+ $(call PyBuild/Compile/Default)
+endef
+endif # python