aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-05-23 21:11:46 -0700
committerRosen Penev <rosenp@gmail.com>2020-05-24 18:37:39 -0700
commit6d100823e975da012210213c6c29f7f4b3e1123c (patch)
treedf3f46d26d4c430796c10a1bb063c8cc7c8c7f04
parentf50e2bde1dcf55f6eba7b27fc6f89ed3fd2496d0 (diff)
libtasn1: fix host build under old GCC
prereq-build.mk says that GCC 4.8 and above is supported. GCC 4.8 defaults to std=gnu89, breaking the build. GCC5 defaults to gnu99. Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--libs/libtasn1/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/libs/libtasn1/Makefile b/libs/libtasn1/Makefile
index d471c6ecf..e5bf554fe 100644
--- a/libs/libtasn1/Makefile
+++ b/libs/libtasn1/Makefile
@@ -39,6 +39,7 @@ define Package/libtasn1/description
Distinguish Encoding Rules (DER) manipulation.
endef
+HOST_CFLAGS += -std=gnu99
TARGET_CFLAGS += -ffunction-sections -fdata-sections
TARGET_LDFLAGS += -Wl,--gc-sections