aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Audia <therealgraysky@proton.me>2024-03-12 08:13:02 -0400
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2024-03-19 23:07:15 +0100
commit6be0617c00bdf5e9309ad3738d09fe498cb9fb0a (patch)
treec647708e510a8edec54a2da78096ac2e4ca46b67
parent79f486b0b23ce76af3b8246d5ad0047df4d9497c (diff)
openssh: bump to 9.7p1
Release notes: https://www.openssh.com/txt/release-9.7 Removed upstreamed patch: 010-better_fzero-call-detection.patch Build system: x86/64 Build-tested: x86/64/AMD Cezanne Run-tested: x86/64/AMD Cezanne Signed-off-by: John Audia <therealgraysky@proton.me>
-rw-r--r--net/openssh/Makefile4
-rw-r--r--net/openssh/patches/010-better_fzero-call-detection.patch52
2 files changed, 2 insertions, 54 deletions
diff --git a/net/openssh/Makefile b/net/openssh/Makefile
index 4a6326fc9..450ab5ff8 100644
--- a/net/openssh/Makefile
+++ b/net/openssh/Makefile
@@ -8,13 +8,13 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=openssh
-PKG_VERSION:=9.6p1
+PKG_VERSION:=9.7p1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://cdn.openbsd.org/pub/OpenBSD/OpenSSH/portable/ \
https://ftp.openbsd.org/pub/OpenBSD/OpenSSH/portable/
-PKG_HASH:=910211c07255a8c5ad654391b40ee59800710dd8119dd5362de09385aa7a777c
+PKG_HASH:=490426f766d82a2763fcacd8d83ea3d70798750c7bd2aff2e57dc5660f773ffd
PKG_LICENSE:=BSD ISC
PKG_LICENSE_FILES:=LICENCE
diff --git a/net/openssh/patches/010-better_fzero-call-detection.patch b/net/openssh/patches/010-better_fzero-call-detection.patch
deleted file mode 100644
index ab4b2dabd..000000000
--- a/net/openssh/patches/010-better_fzero-call-detection.patch
+++ /dev/null
@@ -1,52 +0,0 @@
-From 1036d77b34a5fa15e56f516b81b9928006848cbd Mon Sep 17 00:00:00 2001
-From: Damien Miller <djm@mindrot.org>
-Date: Fri, 22 Dec 2023 17:56:26 +1100
-Subject: [PATCH] better detection of broken -fzero-call-used-regs
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-gcc 13.2.0 on ppc64le refuses to compile some function, including
-cipher.c:compression_alg_list() with an error:
-
-> sorry, unimplemented: argument ‘used’ is not supportedcw
-> for ‘-fzero-call-used-regs’ on this target
-
-This extends the autoconf will-it-work test with a similarly-
-structured function that seems to catch this.
-
-Spotted/tested by Colin Watson; bz3645
----
- m4/openssh.m4 | 12 +++++++++---
- 1 file changed, 9 insertions(+), 3 deletions(-)
-
---- a/m4/openssh.m4
-+++ b/m4/openssh.m4
-@@ -20,18 +20,24 @@ char *f2(char *s, ...) {
- va_end(args);
- return strdup(ret);
- }
-+const char *f3(int s) {
-+ return s ? "good" : "gooder";
-+}
- int main(int argc, char **argv) {
-- (void)argv;
- char b[256], *cp;
-+ const char *s;
- /* Some math to catch -ftrapv problems in the toolchain */
- int i = 123 * argc, j = 456 + argc, k = 789 - argc;
- float l = i * 2.1;
- double m = l / 0.5;
- long long int n = argc * 12345LL, o = 12345LL * (long long int)argc;
-+ (void)argv;
- f(1);
-- snprintf(b, sizeof b, "%d %d %d %f %f %lld %lld\n", i,j,k,l,m,n,o);
-+ s = f3(f(2));
-+ snprintf(b, sizeof b, "%d %d %d %f %f %lld %lld %s\n", i,j,k,l,m,n,o,s);
- if (write(1, b, 0) == -1) exit(0);
-- cp = f2("%d %d %d %f %f %lld %lld\n", i,j,k,l,m,n,o);
-+ cp = f2("%d %d %d %f %f %lld %lld %s\n", i,j,k,l,m,n,o,s);
-+ if (write(1, cp, 0) == -1) exit(0);
- free(cp);
- /*
- * Test fallthrough behaviour. clang 10's -Wimplicit-fallthrough does