aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Iv <zhoreeq@users.noreply.github.com>2020-09-28 06:04:14 -0400
committerGeorge Iv <zhoreeq@users.noreply.github.com>2020-09-28 06:04:14 -0400
commit6b2b73018107a8b588756f09c1fde78a305d3692 (patch)
tree4999bee00f6385b589122b5cb19a58f8bad1c352
parent160179d544d87b73dfc34e8134928e37405723a9 (diff)
yggdrasil: bump to 0.3.15
Signed-off-by: George Iv <zhoreeq@users.noreply.github.com>
-rw-r--r--net/yggdrasil/Makefile6
-rw-r--r--net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch33
2 files changed, 3 insertions, 36 deletions
diff --git a/net/yggdrasil/Makefile b/net/yggdrasil/Makefile
index 8fbf7a845..14f16e418 100644
--- a/net/yggdrasil/Makefile
+++ b/net/yggdrasil/Makefile
@@ -1,12 +1,12 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=yggdrasil
-PKG_VERSION:=0.3.14
-PKG_RELEASE:=2
+PKG_VERSION:=0.3.15
+PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/yggdrasil-network/yggdrasil-go/tar.gz/v$(PKG_VERSION)?
-PKG_HASH:=e8579a04bf289434e7b8caaf621e2c0b853e83cc06f136c4f9e4bfc667df5a27
+PKG_HASH:=25ea85399a142aa7a3d6f6886fd4e0d215116c4c8c33453de43999787d735565
PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-go-$(PKG_VERSION)
PKG_MAINTAINER:=William Fleurant <meshnet@protonmail.com>
diff --git a/net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch b/net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch
deleted file mode 100644
index 682e48526..000000000
--- a/net/yggdrasil/patches/100-drop-log-ygg-over-ygg.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff --git a/src/yggdrasil/tcp.go b/src/yggdrasil/tcp.go
-index 9cca419..45f93a5 100644
---- a/src/yggdrasil/tcp.go
-+++ b/src/yggdrasil/tcp.go
-@@ -25,6 +25,7 @@ import (
-
- "golang.org/x/net/proxy"
-
-+ "github.com/yggdrasil-network/yggdrasil-go/src/address"
- "github.com/yggdrasil-network/yggdrasil-go/src/util"
- )
-
-@@ -386,6 +387,19 @@ func (t *tcp) handler(sock net.Conn, incoming bool, options interface{}, upgrade
- local, _, _ = net.SplitHostPort(sock.LocalAddr().String())
- remote, _, _ = net.SplitHostPort(sock.RemoteAddr().String())
- }
-+ localIP := net.ParseIP(local)
-+ if localIP = localIP.To16(); localIP != nil {
-+ var laddr address.Address
-+ var lsubnet address.Subnet
-+ copy(laddr[:], localIP)
-+ copy(lsubnet[:], localIP)
-+ if laddr.IsValid() || lsubnet.IsValid() {
-+ // The local address is with the network address/prefix range
-+ // This would route ygg over ygg, which we don't want
-+ t.link.core.log.Debugln("Dropping ygg-tunneled connection", local, remote)
-+ return
-+ }
-+ }
- force := net.ParseIP(strings.Split(remote, "%")[0]).IsLinkLocalUnicast()
- link, err := t.link.core.link.create(&stream, name, proto, local, remote, incoming, force)
- if err != nil {
-