aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2022-05-31 18:41:28 -0600
committerPhilip Prindeville <philipp@redfish-solutions.com>2022-05-31 18:42:32 -0600
commit6a30ed6fbd5aa625221607b215521fbec1f06677 (patch)
tree98bcf3c26c05cf79bd3560f90e0f7a13b0c99245
parent5e894cae13d2b6956412f7dd7da36fba752a55c1 (diff)
strongswan: add kernel module dependency on chapoly
Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
-rw-r--r--net/strongswan/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/net/strongswan/Makefile b/net/strongswan/Makefile
index 3cb1c94a6..b202fb358 100644
--- a/net/strongswan/Makefile
+++ b/net/strongswan/Makefile
@@ -668,7 +668,7 @@ $(eval $(call BuildPlugin,attr-sql,SQL based config,+strongswan-charon))
$(eval $(call BuildPlugin,bliss,BLISS crypto,+strongswan-libnttfft +strongswan-mod-mgf1 +strongswan-mod-hmac))
$(eval $(call BuildPlugin,blowfish,Blowfish crypto,))
$(eval $(call BuildPlugin,ccm,CCM AEAD wrapper crypto,))
-$(eval $(call BuildPlugin,chapoly,ChaCha20-Poly1305 AEAD crypto,))
+$(eval $(call BuildPlugin,chapoly,ChaCha20-Poly1305 AEAD crypto,+kmod-crypto-chacha20poly1305))
$(eval $(call BuildPlugin,cmac,CMAC crypto,))
$(eval $(call BuildPlugin,connmark,netfilter connection marking,+libip4tc))
$(eval $(call BuildPlugin,constraints,advanced X509 constraint checking,))