aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:03 +0100
committerJulien Malik <julien.malik@paraiso.me>2022-11-26 15:24:03 +0100
commit69655222fcedb299054bfdff8cf7acf24de4cefa (patch)
tree23b2a86d6288631c64d31c71bf8e3d393ed9c9f4
parentdcbb2cf3d58758c86ba31ece78fa48c33d7ecda9 (diff)
python-sortedcontainers: add package for 2.4.0
Signed-off-by: Julien Malik <julien.malik@paraiso.me>
-rw-r--r--lang/python/python-sortedcontainers/Makefile40
1 files changed, 40 insertions, 0 deletions
diff --git a/lang/python/python-sortedcontainers/Makefile b/lang/python/python-sortedcontainers/Makefile
new file mode 100644
index 000000000..b049eb980
--- /dev/null
+++ b/lang/python/python-sortedcontainers/Makefile
@@ -0,0 +1,40 @@
+#
+# Copyright (C) 2022 Julien Malik <julien.malik@paraiso.me>
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-sortedcontainers
+PKG_VERSION:=2.4.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=sortedcontainers
+PKG_HASH:=25caa5a06cc30b6b83d11423433f65d1f9d76c4c6a0c90e3379eaa43b9bfdb88
+
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+PKG_MAINTAINER:=Julien Malik <julien.malik@paraiso.me>
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-sortedcontainers
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Sorted Containers -- Sorted List, Sorted Dict, Sorted Set
+ URL:=https://grantjenks.com/docs/sortedcontainers
+ DEPENDS:=+python3-light
+endef
+
+define Package/python3-sortedcontainers/description
+ Sorted Containers is an Apache2 licensed sorted collections library, written in pure-Python, and fast as C-extensions.
+endef
+
+$(eval $(call Py3Package,python3-sortedcontainers))
+$(eval $(call BuildPackage,python3-sortedcontainers))
+$(eval $(call BuildPackage,python3-sortedcontainers-src))