aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJiri Slachta <jiri@slachta.eu>2022-11-06 13:41:23 +0100
committerGitHub <noreply@github.com>2022-11-06 13:41:23 +0100
commit6953123f1d90d24e344580c6889b6266944791e8 (patch)
tree68a281905cc6a4c94f8a050d0fdd27cbc046c845
parentb83c56576a79a8be01d5080f72cf540e17feb6a2 (diff)
parent0f9d554f1c34cf9169f5a6832a51acf7adf5f035 (diff)
Merge pull request #19834 from neheb/7
libxslt: update to 1.1.37
-rw-r--r--libs/libxslt/Makefile71
-rw-r--r--libs/libxslt/patches/010-fix-xml2-config-check.patch11
2 files changed, 34 insertions, 48 deletions
diff --git a/libs/libxslt/Makefile b/libs/libxslt/Makefile
index c0db3e37c..b4a3c5747 100644
--- a/libs/libxslt/Makefile
+++ b/libs/libxslt/Makefile
@@ -8,27 +8,24 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=libxslt
-PKG_VERSION:=1.1.34
-PKG_RELEASE:=4
+PKG_VERSION:=1.1.37
+PKG_RELEASE:=$(AUTORELEASE)
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:= \
- http://xmlsoft.org/sources/ \
- ftp://fr.rpmfind.net/pub/libxml/
-PKG_HASH:=98b1bd46d6792925ad2dfe9a87452ea2adebf69dcb9919ffd55bf926a7f93f7f
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNOME/libxslt/$(basename $(PKG_VERSION))
+PKG_HASH:=3a4b27dc8027ccd6146725950336f1ec520928f320f144eb5fa7990ae6123ab4
PKG_MAINTAINER:=Jiri Slachta <jiri@slachta.eu>
PKG_LICENSE:=MIT
PKG_LICENSE_FILES:=COPYING
PKG_CPE_ID:=cpe:/a:xmlsoft:libxslt
-PKG_FIXUP:=autoreconf
-PKG_INSTALL:=1
-PKG_BUILD_PARALLEL:=1
HOST_BUILD_DEPENDS:=libxml2/host
+CMAKE_BINARY_SUBDIR:=openwrt-build
include $(INCLUDE_DIR)/package.mk
include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
include $(INCLUDE_DIR)/nls.mk
define Package/libxslt
@@ -67,36 +64,40 @@ define Package/xsltproc/description
XSLT XML transformation utility.
endef
-CONFIGURE_ARGS += \
- --enable-shared \
- --enable-static \
- --without-python \
- --without-crypto \
- --without-debug \
- --without-mem-debug \
- --without-debugger \
- --without-plugins
-
-HOST_CONFIGURE_ARGS += \
- --with-libxml-prefix=$(STAGING_DIR_HOSTPKG) \
- --without-python \
- --without-crypto \
- --without-debug \
- --without-mem-debug \
- --without-debugger \
- --without-profiler \
- --without-plugins
+CMAKE_HOST_OPTIONS += \
+ -DBUILD_SHARED_LIBS=OFF \
+ -DLIBXSLT_WITH_DEBUGGER=OFF \
+ -DLIBXSLT_WITH_CRYPTO=OFF \
+ -DLIBXSLT_WITH_MEM_DEBUG=OFF \
+ -DLIBXSLT_WITH_MODULES=OFF \
+ -DLIBXSLT_WITH_PROFILER=OFF \
+ -DLIBXSLT_WITH_PYTHON=OFF \
+ -DLIBXSLT_WITH_TESTS=OFF \
+ -DLIBXSLT_WITH_THREADS=ON \
+ -DLIBXSLT_WITH_XSLT_DEBUG=OFF
+
+CMAKE_OPTIONS += \
+ -DBUILD_SHARED_LIBS=ON \
+ -DLIBXSLT_WITH_DEBUGGER=OFF \
+ -DLIBXSLT_WITH_CRYPTO=OFF \
+ -DLIBXSLT_WITH_MEM_DEBUG=OFF \
+ -DLIBXSLT_WITH_MODULES=OFF \
+ -DLIBXSLT_WITH_PROFILER=ON \
+ -DLIBXSLT_WITH_PYTHON=OFF \
+ -DLIBXSLT_WITH_TESTS=OFF \
+ -DLIBXSLT_WITH_THREADS=ON \
+ -DLIBXSLT_WITH_XSLT_DEBUG=OFF
define Build/InstallDev/Xslt
$(INSTALL_DIR) $(1)/usr/bin $(2)/bin $(1)/usr/include/libxslt \
$(1)/usr/include/libexslt $(1)/usr/lib \
- $(1)/usr/lib/pkgconfig $(2)/share/aclocal
+ $(1)/usr/lib/pkgconfig
$(INSTALL_BIN) \
$(PKG_INSTALL_DIR)/usr/bin/xslt-config \
$(2)/bin/
- ln -sf $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
+ $(LN) $(STAGING_DIR)/host/bin/xslt-config $(1)/usr/bin/xslt-config
$(SED) \
's,^\(prefix\|exec_prefix\)=.*,\1=$(STAGING_DIR)/usr,g' \
@@ -107,16 +108,12 @@ define Build/InstallDev/Xslt
$(1)/usr/include/libxslt/
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libxslt.{la,a,so*} \
+ $(PKG_INSTALL_DIR)/usr/lib/libxslt.so* \
$(1)/usr/lib/
$(INSTALL_DATA) \
$(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libxslt.pc \
$(1)/usr/lib/pkgconfig/
-
- $(INSTALL_DATA) \
- $(PKG_INSTALL_DIR)/usr/share/aclocal/* \
- $(2)/share/aclocal
endef
define Build/InstallDev/Exslt
@@ -126,7 +123,7 @@ define Build/InstallDev/Exslt
$(1)/usr/include/libexslt/
$(CP) \
- $(PKG_INSTALL_DIR)/usr/lib/libexslt.{la,a,so*} \
+ $(PKG_INSTALL_DIR)/usr/lib/libexslt.so* \
$(1)/usr/lib/
$(INSTALL_DATA) \
diff --git a/libs/libxslt/patches/010-fix-xml2-config-check.patch b/libs/libxslt/patches/010-fix-xml2-config-check.patch
deleted file mode 100644
index 657705e91..000000000
--- a/libs/libxslt/patches/010-fix-xml2-config-check.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -546,7 +546,7 @@ dnl make sure xml2-config is executable,
- dnl test version and init our variables
- dnl
-
--if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs print > /dev/null 2>&1
-+if test "x$LIBXML_LIBS" = "x" && ${XML_CONFIG} --libs > /dev/null 2>&1
- then
- AC_MSG_CHECKING(for libxml libraries >= $LIBXML_REQUIRED_VERSION)
- XMLVERS=`$XML_CONFIG --version`