aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFlorian Eckert <fe@dev.tdt.de>2020-09-09 17:21:04 +0200
committerFlorian Eckert <fe@dev.tdt.de>2020-09-21 10:17:01 +0200
commit6945528179abe39c589d546cd465d160992dcf7a (patch)
treec4a9580139cfb119c5bd010db6c76e826bda529e
parentf9f3d67a57955c8769513dbd6eb822296e14b362 (diff)
ddns-scripts: update digitalocean.com-v2 to json
Signed-off-by: Florian Eckert <fe@dev.tdt.de>
-rwxr-xr-xnet/ddns-scripts/Makefile17
-rw-r--r--[-rwxr-xr-x]net/ddns-scripts/files/usr/lib/ddns/update_digitalocean_com_v2.sh (renamed from net/ddns-scripts/files/update_digitalocean_com_v2.sh)0
-rw-r--r--net/ddns-scripts/files/usr/share/ddns/services/digitalocean.com-v2.json9
3 files changed, 16 insertions, 10 deletions
diff --git a/net/ddns-scripts/Makefile b/net/ddns-scripts/Makefile
index 56fb0ce38..ed055c92e 100755
--- a/net/ddns-scripts/Makefile
+++ b/net/ddns-scripts/Makefile
@@ -356,17 +356,17 @@ endef
define Package/ddns-scripts_digitalocean.com-v2/install
$(INSTALL_DIR) $(1)/etc/uci-defaults
$(INSTALL_BIN) $(PKG_BUILD_DIR)/files/ddns.defaults $(1)/etc/uci-defaults/ddns_digtalocean.com-v2
+
$(INSTALL_DIR) $(1)/usr/lib/ddns
- $(INSTALL_BIN) $(PKG_BUILD_DIR)/files/update_digitalocean_com_v2.sh $(1)/usr/lib/ddns
+ $(INSTALL_BIN) ./files/usr/lib/ddns/update_digitalocean_com_v2.sh \
+ $(1)/usr/lib/ddns
+
+ $(INSTALL_DIR) $(1)/usr/share/ddns/services
+ $(INSTALL_DATA) ./files/usr/share/ddns/services/digitalocean.com-v2.json \
+ $(1)/usr/share/ddns/services
endef
define Package/ddns-scripts_digitalocean.com-v2/postinst
#!/bin/sh
- # remove old services file entries
- /bin/sed -i '/digitalocean\.com-v2/d' $${IPKG_INSTROOT}/etc/ddns/services >/dev/null 2>&1
- /bin/sed -i '/digitalocean\.com-v2/d' $${IPKG_INSTROOT}/etc/ddns/services_ipv6 >/dev/null 2>&1
- # and create new
- printf "%s\\t%s\\n" '"digitalocean.com-v2"' '"update_digitalocean_com_v2.sh"' >> $${IPKG_INSTROOT}/etc/ddns/services
- printf "%s\\t%s\\n" '"digitalocean.com-v2"' '"update_digitalocean_com_v2.sh"' >> $${IPKG_INSTROOT}/etc/ddns/services_ipv6
# on real system restart service if enabled
[ -z "$${IPKG_INSTROOT}" ] && {
[ -x /etc/uci-defaults/ddns_digitalocean.com-v2 ] && \
@@ -381,9 +381,6 @@ define Package/ddns-scripts_digitalocean.com-v2/prerm
#!/bin/sh
# if NOT run buildroot then stop service
[ -z "$${IPKG_INSTROOT}" ] && /etc/init.d/ddns stop >/dev/null 2>&1
- # remove services file entries
- /bin/sed -i '/digitalocean\.com-v2/d' $${IPKG_INSTROOT}/etc/ddns/services >/dev/null 2>&1
- /bin/sed -i '/digitalocean\.com-v2/d' $${IPKG_INSTROOT}/etc/ddns/services_ipv6 >/dev/null 2>&1
exit 0 # suppress errors
endef
diff --git a/net/ddns-scripts/files/update_digitalocean_com_v2.sh b/net/ddns-scripts/files/usr/lib/ddns/update_digitalocean_com_v2.sh
index 0770ab270..0770ab270 100755..100644
--- a/net/ddns-scripts/files/update_digitalocean_com_v2.sh
+++ b/net/ddns-scripts/files/usr/lib/ddns/update_digitalocean_com_v2.sh
diff --git a/net/ddns-scripts/files/usr/share/ddns/services/digitalocean.com-v2.json b/net/ddns-scripts/files/usr/share/ddns/services/digitalocean.com-v2.json
new file mode 100644
index 000000000..abeac560f
--- /dev/null
+++ b/net/ddns-scripts/files/usr/share/ddns/services/digitalocean.com-v2.json
@@ -0,0 +1,9 @@
+{
+ "name": "digitalocean.com-v2",
+ "ipv4": {
+ "url": "update_digitalocean_com_v2.sh"
+ },
+ "ipv6": {
+ "url": "update_digitalocean_com_v2.sh"
+ }
+}