aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2019-03-24 14:17:26 +0100
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2019-04-01 02:26:29 +0200
commit680eaeb05d4ee42620585df5767063bcbba7921c (patch)
tree45ca4f5aad8f3f2961735fcfd52328d906fca13a
parentbf2521fb4ab853c96828432d4358167f895e6ae1 (diff)
python-yarl: add a new package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
-rw-r--r--lang/python/python-yarl/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/lang/python/python-yarl/Makefile b/lang/python/python-yarl/Makefile
new file mode 100644
index 000000000..d0aed33fa
--- /dev/null
+++ b/lang/python/python-yarl/Makefile
@@ -0,0 +1,45 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=yarl
+PKG_VERSION:=1.3.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=yarl-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/y/yarl/
+PKG_HASH:=024ecdc12bc02b321bc66b41327f930d1c2c543fa9a561b39861da9388ba7aa9
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-yarl
+ SECTION:=lang
+ CATEGORY:=Languages
+ SUBMENU:=Python
+ TITLE:=Yet another URL library
+ URL:=https://github.com/aio-libs/yarl
+ DEPENDS:= \
+ +python3-light \
+ +python3-multidict \
+ +python3-urllib \
+ +python3-idna
+ VARIANT:=python3
+endef
+
+define Package/python3-yarl/description
+Yet another URL library
+endef
+
+$(eval $(call Py3Package,python3-yarl))
+$(eval $(call BuildPackage,python3-yarl))
+$(eval $(call BuildPackage,python3-yarl-src))