aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosef Schlehofer <pepe.schlehofer@gmail.com>2020-10-17 15:03:37 +0200
committerJosef Schlehofer <pepe.schlehofer@gmail.com>2020-10-17 22:25:38 +0200
commit677f73fedda53889b82bb6b94f93e5485427e3b2 (patch)
treeaef951a6e4ce5f0876a8d072bf1de9ad6644369b
parentb24b83782201d477b38fa6cf58f5655652820e23 (diff)
python-babel: add new package
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
-rw-r--r--lang/python/python-babel/Makefile49
1 files changed, 49 insertions, 0 deletions
diff --git a/lang/python/python-babel/Makefile b/lang/python/python-babel/Makefile
new file mode 100644
index 000000000..559e65b83
--- /dev/null
+++ b/lang/python/python-babel/Makefile
@@ -0,0 +1,49 @@
+#
+# Copyright (C) 2019-2020 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-babel
+PKG_VERSION:=2.8.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=Babel
+PKG_HASH:=1aac2ae2d0d8ea368fa90906567f5c08463d98ade155c0c4bfedd6a0f7160e38
+
+PKG_MAINTAINER:=Josef Schlehofer <josef.schlehofer@nic.cz>
+PKG_LICENSE:=BSD-3-Clause
+PKG_LICENSE_FILES:=LICENSE
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-babel
+ SUBMENU:=Python
+ SECTION:=lang
+ CATEGORY:=Languages
+ TITLE:=Internationalization utilities
+ URL:=https://babel.pocoo.org/en/latest/
+ DEPENDS:= \
+ +python3-cgi \
+ +python3-decimal \
+ +python3-distutils \
+ +python3-email \
+ +python3-light \
+ +python3-pytz \
+ +python3-urllib
+endef
+
+define Package/python3-babel/description
+ Babel is an integrated collection of utilities that assist in
+ internationalizing and localizing Python applications
+ with an emphasis on web-based applications.
+endef
+
+$(eval $(call Py3Package,python3-babel))
+$(eval $(call BuildPackage,python3-babel))
+$(eval $(call BuildPackage,python3-babel-src))