aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-30 18:49:41 -0700
committerRosen Penev <rosenp@gmail.com>2020-06-30 19:44:38 -0700
commit6617c644877cef5d15bc739be978b971843a8cc8 (patch)
tree56639cae105f90023304d53c8fa5957263c9be46
parentc11726f14a996e9085ef5d6cb785e8c5f2c4e174 (diff)
open-plc-utils: fix compilation with GCC10
Signed-off-by: Rosen Penev <rosenp@gmail.com>
-rw-r--r--utils/open-plc-utils/Makefile2
-rw-r--r--utils/open-plc-utils/patches/010-gcc10.patch11
2 files changed, 12 insertions, 1 deletions
diff --git a/utils/open-plc-utils/Makefile b/utils/open-plc-utils/Makefile
index d9a0d9fa8..166e7537a 100644
--- a/utils/open-plc-utils/Makefile
+++ b/utils/open-plc-utils/Makefile
@@ -8,7 +8,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=open-plc-utils
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/qca/open-plc-utils.git
diff --git a/utils/open-plc-utils/patches/010-gcc10.patch b/utils/open-plc-utils/patches/010-gcc10.patch
new file mode 100644
index 000000000..957874fbd
--- /dev/null
+++ b/utils/open-plc-utils/patches/010-gcc10.patch
@@ -0,0 +1,11 @@
+--- a/plc/plc.h
++++ b/plc/plc.h
+@@ -498,7 +498,7 @@ struct __packed plcproperty
+ uint8_t DATA_BUFFER [128];
+ }
+
+-plcproperty;
++extern plcproperty;
+
+ #ifndef __GNUC__
+ #pragma pack (pop)