aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVladimir Ermakov <vooon341@gmail.com>2023-04-20 12:23:19 +0200
committerYousong Zhou <yszhou4tech@gmail.com>2023-04-23 18:35:39 +0800
commit65d052d9b830f3fe15b423ea7e13e0891075b070 (patch)
tree2be44f3ff750cc67c7d03811e953ea6b09c7d07e
parent837c0f7f1c33857800b32bb910cfc7d5c6ea674e (diff)
qemu: update to 8.0.0
- Update version to 8.0.0 - Refresh patches - Update configure opttions to disable libdw Signed-off-by: Vladimir Ermakov <vooon341@gmail.com>
-rw-r--r--utils/qemu/Makefile5
-rw-r--r--utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch4
-rw-r--r--utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch10
-rw-r--r--utils/qemu/patches/0010-no-tests.patch4
4 files changed, 12 insertions, 11 deletions
diff --git a/utils/qemu/Makefile b/utils/qemu/Makefile
index 8e5819c40..167df82dc 100644
--- a/utils/qemu/Makefile
+++ b/utils/qemu/Makefile
@@ -9,10 +9,10 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=qemu
-PKG_VERSION:=7.2.0
+PKG_VERSION:=8.0.0
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
-PKG_HASH:=5b49ce2687744dad494ae90a898c52204a3406e84d072482a1e1be854eeb2157
+PKG_HASH:=bb60f0341531181d6cc3969dd19a013d0427a87f918193970d9adb91131e56d0
PKG_SOURCE_URL:=http://download.qemu.org/
PKG_LICENSE:=GPL-2.0-only
PKG_LICENSE_FILES:=LICENSE tcg/LICENSE
@@ -430,6 +430,7 @@ CONFIGURE_ARGS += \
--disable-alsa \
--disable-pa \
--disable-vduse-blk-export \
+ --disable-libdw \
CONFIGURE_ARGS += --target-list='$(foreach target,$(qemu-target-list),$(if $(CONFIG_PACKAGE_qemu-$(target)),$(target)))'
CONFIGURE_ARGS += $(if $(CONFIG_PACKAGE_qemu-ga),--enable-guest-agent)
diff --git a/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch b/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
index e4404a987..42d41305e 100644
--- a/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
+++ b/utils/qemu/patches/0001-configure-allow-disable-fortify_source.patch
@@ -11,9 +11,9 @@ OpenWrt base build system decide flavor of fortify_source to use
--- a/configure
+++ b/configure
-@@ -896,6 +896,8 @@ for opt do
+@@ -895,6 +895,8 @@ for opt do
;;
- --enable-jemalloc) meson_option_parse --enable-malloc=jemalloc jemalloc
+ --disable-vfio-user-server) vfio_user_server="disabled"
;;
+ --disable-fortify-source) fortify_source="no"
+ ;;
diff --git a/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch b/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
index 2c7e39e12..53c82f990 100644
--- a/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
+++ b/utils/qemu/patches/0007-qga-invoke-separate-applets-for-guest-shutdown-modes.patch
@@ -13,17 +13,17 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
--- a/qga/commands-posix.c
+++ b/qga/commands-posix.c
-@@ -74,6 +74,7 @@ static void ga_wait_child(pid_t pid, int
- void qmp_guest_shutdown(bool has_mode, const char *mode, Error **errp)
+@@ -76,6 +76,7 @@ static void ga_wait_child(pid_t pid, int
+ void qmp_guest_shutdown(const char *mode, Error **errp)
{
const char *shutdown_flag;
+ const char *fallback_cmd = NULL;
Error *local_err = NULL;
pid_t pid;
int status;
-@@ -95,10 +96,13 @@ void qmp_guest_shutdown(bool has_mode, c
+@@ -97,10 +98,13 @@ void qmp_guest_shutdown(const char *mode
slog("guest-shutdown called, mode: %s", mode);
- if (!has_mode || strcmp(mode, "powerdown") == 0) {
+ if (!mode || strcmp(mode, "powerdown") == 0) {
shutdown_flag = powerdown_flag;
+ fallback_cmd = "/sbin/poweroff";
} else if (strcmp(mode, "halt") == 0) {
@@ -35,7 +35,7 @@ https://gitlab.alpinelinux.org/alpine/aports/commit/76b81b486480fd9c3294cd420bcf
} else {
error_setg(errp,
"mode is invalid (valid values are: halt|powerdown|reboot");
-@@ -123,6 +127,7 @@ void qmp_guest_shutdown(bool has_mode, c
+@@ -125,6 +129,7 @@ void qmp_guest_shutdown(const char *mode
execl("/sbin/shutdown", "shutdown", "-h", shutdown_flag, "+0",
"hypervisor initiated shutdown", (char *)NULL);
#endif
diff --git a/utils/qemu/patches/0010-no-tests.patch b/utils/qemu/patches/0010-no-tests.patch
index e8bfe84c6..c5e99a1bf 100644
--- a/utils/qemu/patches/0010-no-tests.patch
+++ b/utils/qemu/patches/0010-no-tests.patch
@@ -1,6 +1,6 @@
--- a/meson.build
+++ b/meson.build
-@@ -3142,10 +3142,6 @@ subdir('common-user')
+@@ -3191,10 +3191,6 @@ subdir('common-user')
subdir('bsd-user')
subdir('linux-user')
@@ -11,7 +11,7 @@
# accel modules
tcg_real_module_ss = ss.source_set()
tcg_real_module_ss.add_all(when: 'CONFIG_TCG_MODULAR', if_true: tcg_module_ss)
-@@ -3633,10 +3629,6 @@ subdir('scripts')
+@@ -3682,10 +3678,6 @@ subdir('scripts')
subdir('tools')
subdir('pc-bios')
subdir('docs')