aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2019-11-10 09:25:46 -0800
committerGitHub <noreply@github.com>2019-11-10 09:25:46 -0800
commit65baad1e796f3b1cea807ba4de9fe096d74d71be (patch)
tree678b0bf204412900a266a3c96412bd0710913aba
parentc0d5c29a242a0e367f3fc276e80f411965d1518d (diff)
parent3954356a23b4045caa9a8e2dfd9315c7a947d7ef (diff)
Merge pull request #10498 from LoEE/jpc/master/perl-macos-fix
perl: fixed host compilation of static perl on MacOS
-rw-r--r--lang/perl/Makefile2
-rw-r--r--lang/perl/patches/301-fix_macos_static_linking.patch19
2 files changed, 20 insertions, 1 deletions
diff --git a/lang/perl/Makefile b/lang/perl/Makefile
index 7c7dde21c..465d5768c 100644
--- a/lang/perl/Makefile
+++ b/lang/perl/Makefile
@@ -11,7 +11,7 @@ include perlver.mk
PKG_NAME:=perl
PKG_VERSION:=$(PERL_VERSION)
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=\
https://cpan.metacpan.org/src/5.0 \
diff --git a/lang/perl/patches/301-fix_macos_static_linking.patch b/lang/perl/patches/301-fix_macos_static_linking.patch
new file mode 100644
index 000000000..4b4ef925e
--- /dev/null
+++ b/lang/perl/patches/301-fix_macos_static_linking.patch
@@ -0,0 +1,19 @@
+--- a/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
++++ b/cpan/ExtUtils-MakeMaker/lib/ExtUtils/MM_Unix.pm
+@@ -2738,14 +2738,14 @@ sub _find_static_libs {
+
+ Called by a utility method of makeaperl. Checks whether a given file
+ is an XS library by seeing whether it defines any symbols starting
+-with C<boot_>.
++with C<boot_> (with an optional leading underscore – needed on MacOS).
+
+ =cut
+
+ sub xs_static_lib_is_xs {
+ my ($self, $libfile) = @_;
+ my $devnull = File::Spec->devnull;
+- return `nm $libfile 2>$devnull` =~ /\bboot_/;
++ return `nm $libfile 2>$devnull` =~ /\b_?boot_/;
+ }
+
+ =item makefile (o)