aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-03 21:01:25 -0800
committerIlya Lipnitskiy <ilya.lipnitskiy@gmail.com>2021-02-03 21:01:25 -0800
commit657574f45fd9b9b3f7b0a5090d4f4382071a983d (patch)
tree9b0d18c9eba197b2b3fd72d8c84f724ae0dc3963
parentc01ce53579218319d5f6fb65064fa255b87a1065 (diff)
libs/nss: Don't run nsinstall with QUILT
Allows targets such as prepare, refresh, or update to be run without building dependencies for easier patch maintenance. Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
-rw-r--r--libs/nss/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/libs/nss/Makefile b/libs/nss/Makefile
index 3ebc56ae3..4eafd02d8 100644
--- a/libs/nss/Makefile
+++ b/libs/nss/Makefile
@@ -93,9 +93,11 @@ MAKE_FLAGS += \
#native compile nsinstall
define Build/Prepare
$(call Build/Prepare/Default)
+ifeq ($(QUILT),)
USE_NATIVE=1 OS_REL_CFLAGS="$(HOST_CFLAGS)" LDFLAGS="$(HOST_LDFLAGS)" \
CC="$(HOSTCC)" CPU_ARCH="$(HOST_ARCH)" \
$(MAKE) -C $(PKG_BUILD_DIR)/nss/coreconf/nsinstall
+endif
endef
define Build/Compile