aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2020-06-06 09:32:47 -0700
committerGitHub <noreply@github.com>2020-06-06 09:32:47 -0700
commit64cd2fe01511ab957ecf78d57b5f581bf300cdd2 (patch)
tree00f7fd9aaf61d991351ce4f7ba70e526683280be
parent03349d1fab372943f4cf5e4a78fefa806228c458 (diff)
parent2986f4c24ccacddd58bc1652b97c4ae8fc3c002a (diff)
Merge pull request #12306 from d-bourdon/coova-enable-json
coova-chilli: Add json interface build option
-rw-r--r--net/coova-chilli/Config.in4
-rw-r--r--net/coova-chilli/Makefile8
2 files changed, 10 insertions, 2 deletions
diff --git a/net/coova-chilli/Config.in b/net/coova-chilli/Config.in
index 9202ab7ae..b20788eef 100644
--- a/net/coova-chilli/Config.in
+++ b/net/coova-chilli/Config.in
@@ -26,6 +26,10 @@ config COOVACHILLI_LARGELIMITS
bool "Enable larger limits for use with non-embedded systems"
default n
+config COOVACHILLI_JSONINTERFACE
+ bool "Enable the JSON interface for the CoovaChilli Controller"
+ default n
+
choice
prompt "SSL library"
default COOVACHILLI_NOSSL
diff --git a/net/coova-chilli/Makefile b/net/coova-chilli/Makefile
index 45e763e87..517a02215 100644
--- a/net/coova-chilli/Makefile
+++ b/net/coova-chilli/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=coova-chilli
PKG_VERSION:=1.5
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/coova/coova-chilli/tar.gz/$(PKG_VERSION)?
@@ -24,6 +24,7 @@ PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=0
PKG_CONFIG_DEPENDS:= \
+ COOVACHILLI_JSONINTERFACE \
COOVACHILLI_LARGELIMITS \
COOVACHILLI_MINIPORTAL \
COOVACHILLI_NOSSL \
@@ -43,7 +44,8 @@ define Package/coova-chilli
SECTION:=net
CATEGORY:=Network
DEPENDS:=+kmod-tun +librt +COOVACHILLI_MINIPORTAL:haserl \
- +COOVACHILLI_WOLFSSL:libwolfssl +COOVACHILLI_OPENSSL:libopenssl
+ +COOVACHILLI_WOLFSSL:libwolfssl +COOVACHILLI_OPENSSL:libopenssl \
+ +COOVACHILLI_JSONINTERFACE:libjson-c
TITLE:=Wireless LAN HotSpot controller (Coova Chilli Version)
URL:=https://coova.github.io/
MENU:=1
@@ -111,6 +113,8 @@ define Build/Configure
$(if $(CONFIG_COOVACHILLI_MINIPORTAL),--enable,--disable)-miniportal \
$(if $(CONFIG_COOVACHILLI_USERAGENT),--enable,--disable)-useragent \
$(if $(CONFIG_COOVACHILLI_LARGELIMITS),--enable,--disable)-largelimits \
+ $(if $(CONFIG_COOVACHILLI_JSONINTERFACE),--enable,--disable)-libjson \
+ $(if $(CONFIG_COOVACHILLI_JSONINTERFACE),--enable,--disable)-json \
$(if $(CONFIG_COOVACHILLI_UAMDOMAINFILE),--enable,--disable)-uamdomainfile \
$(if $(CONFIG_IPV6),--with,--without)-ipv6 \
$(if $(CONFIG_COOVACHILLI_WOLFSSL),--with,--without)-cyassl \